Closed (fixed)
Project:
Date
Version:
7.x-2.x-dev
Component:
Date Popup
Priority:
Critical
Category:
Bug report
Assigned:
Unassigned
Reporter:
Created:
27 Apr 2017 at 16:58 UTC
Updated:
18 Oct 2018 at 17:49 UTC
Jump to comment: Most recent, Most recent file
Comments
Comment #2
digitaltodd commentedI am also having this problem. I was working before, I suspect the recent update is the issue.
If the field is not required, disabled in the form, the errors occur.
When the all day check box is selected the errors occur.
The value input for field When Start date is invalid:
The value 21:15 does not match the expected format.
The value input for field When End date is invalid:
The value 21:15 does not match the expected format.
Format of the data going in.
04/27/2017 09:15pm
04/28/2017 10:00am
something is really wrong. This module is not easy to roll back because you have to delete fields using it? Do I have that right?
It looks like a pretty serious issue.
Update on this. New instances of the field work fine, and I can edit pages with this field and change times. In my case, the errors are occurring when I'm trying to create new content of this type.
thanks
Comment #3
Squee3P0 commentedI'm having the same problem. Since there were no database changes in the last few updates, I was able to downgrade the module by just replacing the source code of the module without disabling or uninstalling it.
The problem appears to have been introduced in 7.x-2.10-rc2. Downgrading to 7.x-2.10-rc1 fixed the problem for me.
Comment #4
marco5775 commentedI've the same problem since I've install Date 7.x-2.10.
What is the [temporary] solution ? Patch ? code to modify ?
Thanks in advance.
Comment #5
Squee3P0 commentedThe problem appears to be caused by the patch for this issue that was committed to version 7.x-2.10-rc2:
https://www.drupal.org/node/1037150
I haven't tested their case of a time only field, but I've attached a patch that fixes this issue for me and looks like it would still work for the original issue with time only fields.
Comment #6
Squee3P0 commentedChanging component since the problem is in the Date Popup sub module.
Comment #7
Squee3P0 commentedComment #8
fdverwoerd commentedWe had an issue with
date popupanddate_popup_authoredon node save. Even when we changed nothing, the date would change to current date (created to now).- When running php 5.6.10, it works ok. (without patch)
- When running php 5.3.29, the Authored on date would be set to now. With the patch from comment #5 it would stay/change properly.
Also this was in the errors array:
The value 2 2 does not match the expected format.Drupal php 5.3.Very weird, I am still not sure what's happening. Hopefully this helps a bit.
Comment #9
webservant316 commentedI've have held on updating to 7-.2.10 waiting for this patch to get installed.
What is the status? Why isn't this patch committed?
Comment #10
Kostya19 commentedI had an error when trying save a disabled date field:
The value 14:49:46 does not match the expected format.Patch from #5 solved this issue.Comment #11
jyraya commentedI am evaluating the update from 2.9 to 2.10.
I have Date field using the pop-up calendar widget with as settings:
I have contents created with the version 2.9.
When I update contents with the version 2.10 without changing the date, I did not meet the problem described here.
According to your situation, which additional modules or settings are required in order to have the problem?
Comment #12
jcisio commentedBump to critical because of data loss (node created date is lost on save).
Patch #5 fixes the problem. Bug can only be reproduced on PHP 5.3 and below: https://3v4l.org/J3FmL
Comment #13
jcisio commentedNew patch to adhere coding standards (fixing indentation), so keep the status as RTBC.
Comment #14
jcisio commentedChange title to help people finding this issue.
Comment #15
damienmckennaComment #16
damienmckennaComment #17
webservant316 commentedWow, I see no logical difference between the current and the patched code. Can someone explain what is happening?oops I see the difference in the operators now.
Comment #19
damienmckennaCommitted. Thanks everyone.