When configured to use the "Bind with Users Credentials: Use user's entered credentials to bind to LDAP." option in admin/config/people/ldap/servers/edit/directory in http://cgit.drupalcode.org/ldap/tree/ldap_servers/LdapServerAdmin.class....

The ldap_servers_requirements check dispalyed on admin/reports/status and defined in http://cgit.drupalcode.org/ldap/tree/ldap_servers/ldap_servers.install#n87 will always fail with a "Connection: Failed, check logs for details." error.

patch to follow

Comments

kreynen created an issue. See original summary.

kreynen’s picture

kreynen’s picture

Status: Active » Needs review
afinnarn’s picture

Status: Needs review » Reviewed & tested by the community

I was seeing the same error with the "Bind with Users Credentials" option enabled, and this patch applied cleanly and works to remove the error in the status report. Good jorb!

grahl’s picture

Status: Reviewed & tested by the community » Needs work

Hi

Could you please take a look at https://www.drupal.org/node/2780393? How about combining yours and their patches to check the specific binding method but also doing an anonymous bind initially, as they did to verify that this works?

kreynen’s picture

Will look later today.

afinnarn’s picture

StatusFileSize
new1.08 KB

Hey @grahl, I combined the two patches into this one and tried to add a sensible comment.

afinnarn’s picture

Status: Needs work » Needs review

  • grahl committed 709f619 on 7.x-2.x authored by afinnarn
    Issue #2838389 by kreynen, afinnarn: ldap_servers_requirements will...
grahl’s picture

Status: Needs review » Fixed

Looks good, thanks!

P.S.: Multiline comments should not use // but I didn't change it since 7.x is inconsistent anyway.

Status: Fixed » Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.