Closed (fixed)
Project:
Drupal core
Version:
7.x-dev
Component:
bootstrap system
Priority:
Major
Category:
Bug report
Assigned:
Unassigned
Issue tags:
Reporter:
Created:
11 Feb 2016 at 12:31 UTC
Updated:
10 May 2019 at 11:39 UTC
Jump to comment: Most recent, Most recent file
Comments
Comment #2
zeip commentedAttached is a simple patch to return 500 Internal Server Error instead.
Comment #3
cilefen commentedDoes Drupal 8 do the same thing?
Comment #4
iamEAP commentedRan into this as well. One common way you might hit this is if you have a cache class that throws an exception in the page cache bootstrap phase (e.g. Redis cannot connect or server goes away). This will cause the error logger to attempt to load the maintenance theme, which will attempt to load modules/themes, which will eventually result in a cache_get() attempt (which will throw another exception).
Moving back to needs work as you would want to set response code to 500 regardless of whether or not errors can be displayed.
Comment #5
iamEAP commentedPatch to account for that, with explanation text.
Comment #6
iamEAP commentedUpdated patch with minor change to status text to better align with HTTP standards.
Comment #7
cilefen commentedComment #8
cilefen commentedComment #9
sylvainm commentedTested and it works great, thanks!
Comment #10
tobybellwood commentedWe've just deployed this patch into production for all of our sites (we're using docker with Redis pods, and they'll generate 500's on respawn which were being occasionally cached at the edge as 200's before this patch).
Given the relatively low complexity of the patch and large upside in these scenarios, we'd support this patch making it's way into core.
Comment #11
polHi all,
I would like to push this patch forward.
Do you know if it's already in D8?
Thanks.
Comment #12
polI mostly sure that this is already in D8, see core/includes/errors.inc, around line 265.
Comment #13
polComment #14
polComment #15
fabianx commentedRTBC + 1, let get this in -- it's a good stepping stone (incidentally I also ran into this yesterday)
Comment #17
polFixed! Thanks all !