trying to send email with the correct server configuration I get

Warning: stream_socket_enable_crypto(): SSL operation failed with code 1. OpenSSL Error messages: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed in SMTP->startTLS() (line 344 of /var/www/vhosts/buypichler.com/httpdocs/sites/all/libraries/phpmailer/class.smtp.php).

I am using plesk 12.5 for server configuration
and within plesk I have disabled SSL support
and even if "Use secure protocol" is NO test email is never send

my only work around was with this comment
https://github.com/PHPMailer/PHPMailer/issues/368#issuecomment-110084271
I will prepare a patch if the maintainer needs to incorporate into the module

CommentFileSizeAuthor
#6 2630082.6.patch789 bytesgiorgosk
#3 2630082-3.patch599 bytesgiorgosk

Comments

GiorgosK created an issue. See original summary.

giorgosk’s picture

Issue summary: View changes
giorgosk’s picture

Category: Feature request » Bug report
StatusFileSize
new599 bytes

I will make this into a bug but feel free to change it to a feature request

giorgosk’s picture

Status: Active » Needs review

please review if it makes any problems with other setups

Status: Needs review » Needs work

The last submitted patch, 3: 2630082-3.patch, failed testing.

giorgosk’s picture

Status: Needs work » Needs review
StatusFileSize
new789 bytes

new diff patch hope format is OK now

Status: Needs review » Needs work

The last submitted patch, 6: 2630082.6.patch, failed testing.

oadaeh’s picture

According to another comment in the thread you linked to:

PHP 5.6 verifies SSL certificates by default, and if your cert doesn't match, it will fail with this error. The correct solution is to fix your SSL config - it's not PHP's fault!

https://github.com/PHPMailer/PHPMailer/issues/368#issuecomment-75785475

Your recommended fix will make it so that all sites using this module will never correctly check any SSL certs.
I think a better "fix" is to offer that as an administrative option, and offer it on a per server basis, not globally.

giorgosk’s picture

@oadaeh
I agree so it stays needs work

oadaeh’s picture

Category: Bug report » Support request
Status: Needs work » Closed (won't fix)

Administrative options for SSL settings are in the 7.x-3.x-dev branch and will be in a tagged release "soon," so I'm closing this as won't fix, due to the reasons I outlined previously.