When a file of the same name, as the file being uploaded, already exists in either the public:// (original) files folder or the fe_paths destination folder the file will fail to move properly.

Incrementing of the file names is the default behavior of file uploads and this should be accounted for on the original upload and allowed to occur on the move.

Comments

kerby70 created an issue. See original summary.

kerby70’s picture

See attached patch.

sgdev’s picture

Version: 7.x-2.0-alpha3 » 7.x-2.x-dev
Status: Needs review » Needs work

Seems as though this patch was created against 7.x-2.0-beta3 rather than 7.x-2.x-dev. Patches should always be created against the -dev version.

frodri’s picture

Patch in #2 assumes the main module file is located in a sub-directory. I've attached a copy of that same patch with the correct directories set up.

sgdev’s picture

Status: Needs work » Needs review

Agreed, and thanks for the update. Setting to review.