When using field group on a drupal 8 website one can create a field group in the user configuration page.

However, after adding the group (group+technical name) the form to adapte the user configuration becomes inusable.

When looking in the logging following error line can be found:

mod_fcgid: stderr: Uncaught PHP Exception Symfony\\Component\\Routing\\Exception\\RouteNotFoundException: "Route "field_ui.field_group_delete_user" does not exist." at /home/****/public_html/core/lib/Drupal/Core/Routing/RouteProvider.php line 191

Comments

Anonymous’s picture

jerrevds created an issue. See original summary.

Anonymous’s picture

==>issue seems to be fixed after an update of RC2 to RC3

webflo’s picture

Status: Active » Fixed

I couldn't reproduce it in RC3

Status: Fixed » Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.

jordanpagewhite’s picture

Status: Closed (fixed) » Needs work

I just experienced this issue exactly as it is describe in the issue summary using the rc4 release. If you need other information, please let me know on here. It seems that the error should be able to be replicated simply by downloading the rc4 release, and some fields to User, and then adding a fieldgroup on the User>Form Display page and then clicking 'Save'.

zuuperman’s picture

Tried to reproduce this, but everything is working here. I followed same steps, on a clean drupal 8 site.

The route field_ui.field_group_delete_user, should exist, as a route is created for every fieldable entity type on the site.
So unless another module is blocking the 'alter routes' event, this should work.

zuuperman’s picture

Status: Needs work » Postponed (maintainer needs more info)
Anonymous’s picture

Issue summary: View changes
zuuperman’s picture

Status: Postponed (maintainer needs more info) » Active

Closing this as duplicate of #2645616. Found the problem, the fix should be committed this evening.

jordanpagewhite’s picture

@zuuperman Thanks! I really appreciate your efforts on this. I'm not using field_group on a d8 site right now, but I'm sure that I will use it sometime in the coming months. If you need more specific information from me to reproduce the issue, let me know.

webflo’s picture

zuuperman’s picture

Status: Active » Closed (duplicate)