After Installation of D8(Beta), during setting up the config of Database, following message is shown:

Fatal error: Maximum execution time of 30 seconds exceeded in
D:\xampp\htdocs\drupaleight\core\lib\Drupal\Core\Database\Statement.php on line 64.

It clearly shows that either maximum execution time is causing error, or there is some wrong with Statement.php @ line#64.
Since I am using XAMPP as my default AMP stack, I don't know that is that issue is related to AMP stack or D8 corefiles.

The URL alias for the error is below:
http://localhost/drupaleight/core/install.php?rewrite=ok&langcode=en&pro...

This issue don't comes with D7, it runs successfully on my AMP stack, i.e. XAMPP.

CommentFileSizeAuthor
Untitled1.png52.16 KBQuswar
Untitled.png411.77 KBQuswar

Comments

Quswar created an issue. See original summary.

Quswar’s picture

I think it's not a big issue, if we somehow increase the max execution time, then maybe the problem can be solved

tr’s picture

Assigned: Quswar » Unassigned
Category: Bug report » Support request
Issue tags: -drupal8, -database, -Fatal error: maximum execution time of 30 seconds exceeded
cilefen’s picture

Category: Support request » Bug report
Status: Active » Closed (outdated)

This should not happen on release versions if requirements are met.