Problem/Motivation

Even if Erpal is a lot faster than OpenAtrium, is still heavy on database, due to the inner nature of ERP ( especially with node_access joins)
PostgreSQL rocks with join algorithms ( see http://posulliv.github.io/2012/06/29/mysql-postgres-bench/ ) and performace improvements are visibile also in Devel Queries.

Choose installation method

7.x-2.2 version is using by default the quick installation, which will fails on PostgreSQL, because is based on a predefined MySQL dump database.
Use instead 7.x-2.x-dev with standard default installation.

Temporary core patches

I say temporary, because they will be committed in core

Fixed issues

Even some of them are reported with needs work status, they are stable, but ugly fixes

Other issues

In the first place, we considered #2447871: PDOException: SQLSTATE[42S22]: Column not found: 1054 Postgres related. But it was present also on MySQL, fixed by updating Relation Module.

Conclusion

As you can see, it was adventurous to make Erpal work with PostgreSQL, but it worth the effort, because Erpal is a really beautiful piece of software.
Generally, this isn’t Erpal fault, is all about known core issues and contributed modules, which are expected in a large Drupal distribution.
Even there was some tricky issues, PDOException:Invalid text representation is the usual suspect , where MySQL silently fails anyway.
The final result is stable.

We know that we “have killed some kittens”, but we needed to provide fast results with Erpal. This is a reason we have posted anyway... maybe somebody could dive in with nice fixes, easily overcoming initial issues.

Comments

Drupa1ish’s picture

Issue summary: View changes
Drupa1ish’s picture

Issue summary: View changes
Drupa1ish’s picture

Issue summary: View changes
Drupa1ish’s picture

Drupa1ish’s picture

Issue summary: View changes
Drupa1ish’s picture

Drupa1ish’s picture