Closed (fixed)
Project:
Drupal core
Version:
8.0.x-dev
Component:
sqlite db driver
Priority:
Normal
Category:
Task
Assigned:
Reporter:
Created:
3 Apr 2015 at 16:42 UTC
Updated:
29 Apr 2015 at 08:34 UTC
Jump to comment: Most recent, Most recent file
Comments
Comment #1
amateescu commentedPatch and a test run for the Database group attached. Note that ConnectionUnitTest is being fixed in #2463321: Serializing the database connection is dangerous and error-prone, make it unserializable again.
Comment #2
larowlanAre there any security releases in nine years? That would make this more than normal.
Comment #3
amateescu commentedApparently, SQLite never had any security release... that's quite impressive :)
http://www.cvedetails.com/vulnerability-list/vendor_id-9237/Sqlite.html has only 4 entries and neither of them is a vulnerability in SQLite itself. I also can't find anything in http://www.sqlite.org/changes.html.
Comment #4
alexpottThis issue is a normal task so we need to outline how it fits within the allowable Drupal 8 beta criteria. Can someone add Drupal 8 beta phase evaluation template to the issue summary.
Can't we just delete the entire class then?
Comment #5
amateescu commentedNope, all drivers have to provide empty class implementations for each abstracted db operation, see http://cgit.drupalcode.org/drupal/tree/core/lib/Drupal/Core/Database/Dri... for example.
Added a beta evaluation.
Comment #6
amateescu commentedComment #7
webchickSeems fine to me. Back to Alex.
Comment #8
alexpottThinking about this I think we shouldn't be in the habit of requiring things we don't need - we had issues with PHPUnit requiring the latest version of PHP for no reason so we shouldn't do the same to other projects. Let's make the requirement
3.6.8unless there is a compelling reason that we want3.6.20- and if there is we should document it. One valid reason to bump it to3.7.9might be because that's what DrupalCI will test it on - but that should be in another issue once we have sqlite testing.Comment #9
amateescu commentedI agree with the reasoning from #8.
Comment #10
alexpottCommitted 561834c and pushed to 8.0.x. Thanks!
Thanks for adding the beta evaluation to the issue summary.
Comment #12
larowlanSo, it turns out that there *are* security issues in sqllite, that were fixed in 3.8.9 but they just didn't publicize it *or* provide CVEs
See http://seclists.org/fulldisclosure/2015/Apr/31
So should we bump that far or are the issues identified not worth worrying about?
Comment #13
webchickHm. 3.8.9 isn't in any of the distros mentioned in the issue summary, so that seems like it'd make it significantly harder for users.
Comment #14
larowlanYeah... so maybe that's back to fixed - just wanted to get @amateescu's opinion.
Comment #15
alexpottI think that our minimum dependency should relate to which features we need - not the security status of the release. We might want to recommend that users use 3.8.9 and above though.
Comment #16
amateescu commentedYep, IMO it's the job of distributions to apply security patches to (very old) packages they ship.