It seems that we need to have ctools enabled in the 6.x-2.x site to be able to do: #2262575: [meta] Upgrade path Aegir 2.x to 3.x

We should document that in the release/upgrade notes ...

We could also add it to 6.x-2.x now ... but that still would need documentation.

Comments

helmo’s picture

Status: Active » Needs review
FileSize
883 bytes
408 bytes

There patches for hosting and hostmaster should do it.

ergonlogic’s picture

Status: Needs review » Needs work

Should we consider also making ctools a dependency of hosting-6.x-2.x, then? Without that, a site administrator could just disable it again.

helmo’s picture

Status: Needs work » Needs review

That's what pre_upgrade_add_ctools-2267057-1.patch is supposed to add to the hosting.info file.

ergonlogic’s picture

Status: Needs review » Reviewed & tested by the community

Oops, I missed that.

  • helmo committed fe729f7 on 6.x-2.x
    Issue #2267057 by helmo: Pre-upgrade add ctools to 6.x-2.x .
    
helmo’s picture

Version: 7.x-3.x-dev » 6.x-2.x-dev
Status: Reviewed & tested by the community » Fixed

Status: Fixed » Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.