The project page should be updated to point users to the "bower" file to find the current minimum version of jQuery needed for the latest Bootstrap. This is what the Bootstrap docs do. The minimum jQuery needed for Bootstrap 3.1.1 is >= 1.9.0.

Comments

js’s picture

Thanks. This comment solved my image carousel "prev" and "next" problem. I was using 1.8.

ryan.armstrong’s picture

Assigned: Unassigned » ryan.armstrong
Status: Active » Fixed

Thanks for the heads up guys. I've updated the main page to reflect the different jQuery requirements for Bootstrap 2 and Bootstrap 3. Good catch!

markcarver’s picture

Component: Documentation » Code
Assigned: ryan.armstrong » Unassigned
Category: Task » Feature request
Status: Fixed » Active

I'd like to keep this open. I think we might be able to include this file and set the version automatically (to help eliminate jquery related issues)? Not sure yet, I'll see what I come up with.

WorldFallz’s picture

Not sure if this requires a new issue, but I can't seem to use anything higher than jquery 1.8 without breaking the teaser summary (shows all the time) or hierarchical_select.

It's not an issue for the bootstrap theme, other than the fact if requires jquery 1.9 and that's where the breakage begins (it breaks with bartik as well-- tested on a simplytest.me site with a clean install).

I couldn't locate any issues in the jquery_issue queue referencing this for any d7 version (there's one for d6), so I'm curious as to how so many folks are using bootstrap if this is broken?

markcarver’s picture

@WorldFallz, the issue you are referring to is #2282541: Hide summary in text.js not working in jQuery 1.9+ and it's actually a core issue.

Regarding hierarchical_select or any other module for that matter, an issue should be filed in their queues so they can fix it.

WorldFallz’s picture

Thanks! It never occurred to me to look for a core issue. And I'm winding my way through the HS issue queue now to see if if I need to create a new issue there.

You might want to mention that issue on the project page to save yourself some issues from lost users. Although it has nothing to do with this theme, just about anyone installing bootstrap which requires jquery 1.9+ now, will likely find it for that reason.

markcarver’s picture

I'm not too worried about it. I haven't really seen too many issues about it yet and it's already schedule to likely land in the next bug fix release of core.

WorldFallz’s picture

True enough.

Just to close the loop, the hs bug was totally unrelated, but I wanted to reference it in case this comes up in someone's search: #2315453: js error: Console error: TypeError: $.browser is undefined.

markcarver’s picture

Status: Active » Closed (fixed)

I think the only thing we can really do now is move forward in the direction of theme specific jQuery versions (as is the case with the 7.x-3.x branch of jQuery Update) and provide a theme setting in the .info file, as has already been done:

http://cgit.drupalcode.org/bootstrap/tree/bootstrap.info?h=7.x-3.x#n139