Right now we know if there is any issue with the temp directory after the views is run and when views data export tries to run through the whole process. In case of batch job you don't know until the batch job is completed and then it throws the error

The file permissions could not be set on temporary://views_plugin_display.

So add a check in the hook_requirements will display error in the status report and will show the proper status whether the folder is writable or not.

Comments

junedkazi’s picture

Status: Active » Needs review
StatusFileSize
new1.18 KB
steven jones’s picture

Status: Needs review » Fixed

Thanks so much for the patch. Committed to 7.x-3.x.

Status: Fixed » Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.