In D6 a new button was added to the node edit form. This button splits up the body input field into two fields; one with the contents before the cursor location, and one with the contents after the cursor location. See http://drupal.org/node/107061.
After much debate it was decided the label on the button would be "Split summary at cursor". When split up, a check box is visible "Show summary in full view". The rationale for using summary was that teaser would not be understood by first time users.
Though this is great new functionality, I believe the user-interface can be improved. I'm not yet completely sure how to do this though, just thinking out loud. I would like your input.
First a few facts:
- The concept of teaser is never explained, neither on the help pages nor in the handbooks.
- The button is labeled "Split summary at cursor". But it doesn't split the summary, it splits the body.
- Currently, after the split the summary/teaser field is labeled "Body", while the body has no label at all.
- Currently, if "Show summary in full view" is checked the teaser field acts like a teaser (or introduction). If unchecked it acts like a summary.
- In usability consistency is king.
Okay, now my opinion:
- Teaser should have
- a definition on the help page (/admin/help?)
- a description on node/add
- Use of words like teaser should be consistent throughout Drupal. Don't call it summary on one page, and teaser on another.
- What is a teaser anyway? Maybe this is an explanation:
Drupal has several ways of displaying nodes. One of them is page view, one of them is teaser view. In page view Drupal displays the whole node. In teaser view Drupal displays only the title and the teaser. You decide what the teaser contains:
- it can be empty, thus displaying nothing
- it may contain the first part of the body; either you decide which part, or Drupal can decide for you
- it may be a separate piece of text, e.g. containing a summary of the whole page
- The button label is confusing. Use "split off teaser at cursor" or "separate teaser at cursor" or "make text before cursor the teaser". I guess I prefer "separate teaser" as it suggests, well, a separate teaser ;-)
- The field labels should be correct. See ximo's mockup for how it should be.
- The checkbox label is confusing. With the field labels right you can avoid "summary" altogether (look at ximo's mockup).
- As an end-user I'm not interested in how stuff is stored. I'm interested in how it is displayed. If I see two fields I see two fields, not "a teaser that is part of the body".