Hi guys,

Just following up quickly with a discussion over in Views:
>Undefined index: commerce_product in views_handler_field_field->access()
http://drupal.org/node/1477054

We're currently wondering if this could be something similar to another issue encountered previously (already closed):
Notice: Undefined index: commerce_product in field_views_field_default_views_data()
http://drupal.org/node/1265152 [Closed]

If anybody using commerce stumbles on this issue, I detailed how I managed by-passing the problem:
http://drupal.org/node/1477054#comment-6437150
The problem is clearly explained in that ticket and it seems I wasn't the only one to encounter it.

I thought perhaps this could be of help to others and maybe get some potential developers to narrow down the problem to try to come up with a patch, if any would be needed.
Maybe this ticket should be marked as duplicate and the original post (http://drupal.org/node/1477054) should be moved over from Views to the Drupal Commerce module tracker.

Any feedback on this issue would be greatly appreciated.

Thanks for your help in advance.

Comments

rszrama’s picture

Status:Active» Closed (duplicate)

Yeah, no reason to duplicate the issue here. I'll follow along in that other issue since it actually has a Views export to work with and some recent comments. If we need to fix something in Commerce, I'll move it over, but it's also worth noting that I may have already fixed the issue in the various Views / entity access fixes I've made since last October.