When using this module with the amazon s3 module i run into a problem when using the remote url option.
The error i receive is

The specified file temporary://apachelogo.gif could not be copied, because the destination directory is not properly configured. This may be caused by a problem with file or directory permissions. More information is available in the system log.

the system log says

Upload error. Could not move uploaded file apachelogo.gif to destination s3://apachelogo.gif.

CommentFileSizeAuthor
#1 filefield_sources_s3.patch2.32 KBquicksketch

Comments

quicksketch’s picture

Category: support » feature
Status: Active » Fixed
StatusFileSize
new2.32 KB

Which S3 module are you using? I read through http://drupal.org/project/amazons3, because it seems the most popular and found that our file_prepare_directory() checks will always fail with remote stream wrappers, because they don't know how to translate "is_dir" calls. FileField Sources tries to make sure that the destination is valid before it copies the files, but this doesn't seem possible in S3. For now what I've done is add another check for chmod() to that will pass with the amazons3 module because it always returns TRUE for chmod() checks.

Status: Fixed » Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.