Hi,
I want to install http://drupal.org/project/geshifilter module but it requires the Libraries API 2.x.
Why there is no a new releazse to libraries 2
how can i update the module to 2.x ver? ( alpha ver )
thanks.

Comments

ntigh52’s picture

Issue summary:View changes

1

ntigh52’s picture

Version:7.x-2.x-dev» 7.x-2.0-alpha2

Did that alpha2 ver Stable and can be used and replace the 1 ver?
Thanks

tstoeckler’s picture

Status:Active» Postponed

Well, it is stable in that the current module will almost surely not break anything on your site. It is unstable in so far as future alpha versions might be incompatible with the current version of implementing modules (in this case geshifilter). So stuff might break on upgrading. Either way a stable 2.x release is still a ways off.

sun’s picture

Title:new release» Stable 2.0 release?
Version:7.x-2.0-alpha2» 7.x-2.x-dev
Status:Postponed» Active

Based on what we discussed, should we just simply publish the current code as stable 2.0 release, thus lock it down in terms of features, so we can move on with 3.x?

tstoeckler’s picture

Even though I feel some current issues with the 2.x alpha make it unstable, considering that
1. the last commit was 7 months ago
2. it took me 2 weeks to even reply here (so at least I am not a very diligent maintainer currently)
I think it makes sense to give people who are successfully using the current release a stable.

Marking RTBC. Since this is kind of a big decision, I'll let this sit a few days before actually tagging the release. *crossingfingersthatidontforget*

@sun If time allows, of course, help yourself! :-)

tstoeckler’s picture

Status:Active» Reviewed & tested by the community

...right...

tstoeckler’s picture

klonos’s picture

I like to help with testing the latest and greatest. Let us know when you have a 3.x dev built ready for download ;)

tstoeckler’s picture

Status:Reviewed & tested by the community» Fixed

http://drupal.org/node/1704592

I tagged a 7.x-2.0 couple hours ago. Hope I didn't mess anything up. I re-ran all tests and checked library loading manually just to be sure.

klonos’s picture

Title:Stable 2.0 release?» Libraries API: Stable 2.0 release?

Thanx Tobias!

PS: I know this issue will slowly bury itself down the list of our issues since it's now fixed, but nevertheless giving it a less vague title for our dashboards.

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

klonos’s picture

Version:7.x-2.x-dev» 7.x-2.0

...actually ;)

klonos’s picture

Issue summary:View changes

2