The term "datastore" referring to the data in file is confusing and has been changed to "configstore" in D8. We should change this to match or possibly even consider better names as proposed by the community.

CommentFileSizeAuthor
#14 1510064-rename-datastore-14.patch37.13 KBbojanz
PASSED: [[SimpleTest]]: [MySQL] 655 pass(es). View
#10 1510064-rename-datastore-9.patch35.78 KBbojanz
FAILED: [[SimpleTest]]: [MySQL] 614 pass(es), 41 fail(s), and 0 exception(s). View
#8 1510064-rename-datastore-8.patch36.47 KBbojanz
FAILED: [[SimpleTest]]: [MySQL] 603 pass(es), 52 fail(s), and 11 exception(s). View
#7 1510064-rename-datastore.patch29.2 KBbojanz
FAILED: [[SimpleTest]]: [MySQL] 614 pass(es), 41 fail(s), and 0 exception(s). View
#2 1510064.configstore.2.patch66.99 KBdagmar
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch 1510064.configstore.2.patch. Unable to apply patch. See the log in the details link for more information. View
#1 1510064.configstore.patch53.14 KBdagmar
PASSED: [[SimpleTest]]: [MySQL] 151 pass(es). View
Members fund testing for the Drupal project. Drupal Association Learn more

Comments

dagmar’s picture

Status: Active » Needs review
FileSize
53.14 KB
PASSED: [[SimpleTest]]: [MySQL] 151 pass(es). View

Let use configstore by now.

dagmar’s picture

FileSize
66.99 KB
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch 1510064.configstore.2.patch. Unable to apply patch. See the log in the details link for more information. View

I forgot add the constants. Now all occurences of datastore were removed form the module.

dagmar’s picture

#2: 1510064.configstore.2.patch queued for re-testing.

Status: Needs review » Needs work

The last submitted patch, 1510064.configstore.2.patch, failed testing.

dagmar’s picture

Version: 7.x-1.x-dev » 7.x-2.x-dev
bojanz’s picture

Title: Change "datastore" to "configstore" or something better to match changes in D8 » Rename activestore and datastore
Status: Needs work » Active

Core doesn't use "configstore" anymore.
Current terms are bad for UX, they are not immediately obvious.

The terms I see used in core are "active configuration" and "staged configuration", so maybe we should go down that road (giving us labels such as "Write active configuration to staging" and "Import from staging")
Alternatively, perhaps using "database store" and "filesystem store" (or storage) would be obvious enough, but matching core has obvious benefits.

bojanz’s picture

Status: Active » Needs review
FileSize
29.2 KB
FAILED: [[SimpleTest]]: [MySQL] 614 pass(es), 41 fail(s), and 0 exception(s). View

So, something like this perhaps.

Note: the README would need to be rewritten.

bojanz’s picture

FileSize
36.47 KB
FAILED: [[SimpleTest]]: [MySQL] 603 pass(es), 52 fail(s), and 11 exception(s). View

Here's some more, seems complete now.
Keep in mind this is completely untested.

Status: Needs review » Needs work

The last submitted patch, 1510064-rename-datastore-8.patch, failed testing.

bojanz’s picture

Status: Needs work » Needs review
FileSize
35.78 KB
FAILED: [[SimpleTest]]: [MySQL] 614 pass(es), 41 fail(s), and 0 exception(s). View

Status: Needs review » Needs work

The last submitted patch, 1510064-rename-datastore-9.patch, failed testing.

bojanz’s picture

Status: Needs work » Needs review

#10: 1510064-rename-datastore-9.patch queued for re-testing.

Status: Needs review » Needs work

The last submitted patch, 1510064-rename-datastore-9.patch, failed testing.

bojanz’s picture

Status: Needs work » Needs review
FileSize
37.13 KB
PASSED: [[SimpleTest]]: [MySQL] 655 pass(es). View

Should fix the tests.