I have installed the galleria module and put the galleria js files in my libraries folder.

I have also created a content type and a galleria view. I then upload an image and I get this error

Image not found http://localhost/mysitename/sites/default/files/styles/galleria_thumb/pu....

I am running Drupal 7.9.

I also get this error message

Notice: Undefined index: en in theme_views_view_galleria() (line 87 of C:\wamp\www\mysitename\sites\all\modules\galleria\theme\theme.inc).

Comments

kroimon’s picture

Title:Image not found http://localhost/mysitename/sites/default/files/styles/galleria_thumb/public» Views integration: "Undefined index: en in theme_views_view_galleria() line 87"
Version:7.x-1.0-beta2» 7.x-1.x-dev
Component:Miscellaneous» Code

The Views integration seems to be a little buggy on multi-language and non-english installations.

I'm no Views expert myself, so we need someone to rewrite that part of the module.

Road Kill’s picture

Yeah I have been hearing a lot about multi-language and non-English installations which seems to be causing problems for a lot of modules, and to be honest I don’t really know much about this multi-language and non-English installations issue. I think I to do some reading on the subject. My php is at best very basic but still learning so I won’t be of much help adding useful code to help solve this problem. However I am always happy to do testing if you need somebody to test patches.

Thanks for the reply.

lukpe’s picture

Quick & dirty solution - change line 92 in theme.inc from:
$item = $row->_field_data[$view->base_field]['entity']->{$img_field_name}[$lang][0];
to:
$item = $row->_field_data[$view->base_field]['entity']->{$img_field_name}['und'][0];

miro_dietiker’s picture

Status:Active» Closed (duplicate)
Road Kill’s picture

Thanks Lukpe will give this a try.

dendritic’s picture

I still get the error with that patch.

maxplus’s picture

Hi,

thanks, #3 worked for me with the current DEV version of Galleria.

Max

bendev’s picture

#3 is also working for me.
Is it commited to next release ?

sujomuc’s picture

#3 worked for me, too. Thanks.