It's currently unclear what version we are using (most likely 2.3). We should at least try to found out how much longer our version will be supported, and consider upgrading to v3.

Oldhttps://www.google.com/analytics/feeds/data
Newhttps://www.googleapis.com/analytics/v3/data/ga

One issue that's come up is the version we have may not allow access to the configuration data, see #1345542: pull defaultPage from management API, instead of assuming index.html.

Comments

Vacilando’s picture

Whether or not, it will be replaced by version 2.4 in less than 6 months (http://analytics.blogspot.com/2011/12/introducing-google-analytics-core....). However, version 3 is clearly the way to go in the longer term.

raspberryman’s picture

Title:Upgrade to Core Reporting API v3.0» Upgrade to Core Reporting API v3.0 / OAuth 2.0
Assigned:Unassigned» raspberryman

Oye! grendzy let's book ourselves some time to rewrite. Might as well get us up to OAuth 2.0 in the same effort.

raspberryman’s picture

Status:Active» Needs review

Updated to v3: http://drupal.org/node/1541230

I'm leaving OAuth at v1.0 for now; v2.0 and Google Console drove me bonkers. I'll revisit it later :)

Also added support for default page: #1345542: pull defaultPage from management API, instead of assuming index.html

mikhailian’s picture

Any chance the upgrade will be ported in the 6.x branch?

ajayg’s picture

Version:7.x-1.x-dev» 6.x-1.x-dev

May be the version number now need to change to backport to 6x?

ajayg’s picture

Status:Needs review» Active
drpl’s picture

Component:Code» Reports module

subscribe