I am receiving this error when trying to configure search api after install:

PDOException: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'drupal-ehps.search_api_server' doesn't exist: SELECT base.id AS id, base.name AS name, base.machine_name AS machine_name, base.description AS description, base.class AS class, base.options AS options, base.enabled AS enabled, base.status AS status, base.module AS module FROM {search_api_server} base; Array ( ) in EntityAPIController->query() (line 152 of /Users/gerben/Documents/zelf/websites/drupal-ehps/sites/all/modules/entity/includes/entity.controller.inc).

This seems related to a previous install of the search api module which i uninstalled. There seems to be left over information in the system so when I install the module it thinks there is a server already? I tried deleting search api data in the mysql db but to no avail.

What happens is this:
- I install search api
- when i try to enable it I notice it is already enabled
- when I try to configure I get the error above

I guess I might have made a mistake when uninstalling search api before. Is there anything I could do manually to do a complete uninstall and retry?

Many thanks,
Gerben

Comments

cloudbull’s picture

is that the system table still got search_api's row after you disabled & uninstalled the module ?

Keith

Gerben Zaagsma’s picture

Status: Active » Closed (fixed)

Thanks! That might be the case yes; I solved this by reverting to an old backup that did not have the problem so I cannot find it out anymore. Now everything works fine.

Gerben

andsil1’s picture

Issue summary: View changes

I have the exact same problem, I just got a version of a website locally and after importing the dump I tried accessing the directory and I got the WSOD because of this error, anybody know what causes it and how to fix it ?