Hello, after upgrading to Token 6.x-1.17 all tokens in rules actions of type "Send a mail to an arbitrary mail address" stopped to work.

e.g. I got:

Titolo: [node:title]
Autore: [author:realname] ( [author:mail] )
Link di verifica: [:global:site-url]node/[node:nid]

Pagina degli avvisi pubblicati: [:global:site-url]notices
Pagina di gestione degli avvisi da pubblicare: [:global:site-url]manage_notices

After reverting to 6.x-1.16 I got it back working as expected:

Titolo: Dr. Antonello Lobianco
Autore: ANTONELLO LOBIANCO ( a.lobianco@univpm.it )
Link di verifica: http://www.econ.univpm.it/node/53911

Pagina degli avvisi pubblicati: http://www.econ.univpm.it/notices
Pagina di gestione degli avvisi da pubblicare: http://www.econ.univpm.it/manage_notices

And yes.. I did upgradedb and also cc.. :-)

#3 1329196-token-fix-replace-rules.patch843 bytesDave Reid
PASSED: [[SimpleTest]]: [MySQL] 196 pass(es).
[ View ]


perpignan’s picture

I have the same problem !
I did /upgrade.php and flush all cache but .. tokens aren't replace in mail.

fonant’s picture

I have this problem too.

Same bug as http://drupal.org/node/1328752

Dave Reid’s picture

Version:6.x-1.17» 6.x-1.x-dev
Status:Active» Needs review
new843 bytes
PASSED: [[SimpleTest]]: [MySQL] 196 pass(es).
[ View ]

Can you please test the following patch?

castelar’s picture

Patch didn't work for me.

Dave Reid’s picture

I have added some debugging code to 6.x-1.x-dev release that will help trace what function is responsible for calling this incorrectly. Please download the 6.x-1.x-dev release in about 12 hours to help me debug this further.

Dave Reid’s picture

Title:All tokens broken in rules->send a mail (reverting to 6.x-1.16 works)» Rules integration broke in 6.x-1.17
svinod999’s picture

same problem faced... subscribing...

tobiberlin’s picture

Same with action "page redirection"... wanted to redirect a user to "/user/[account:uid]/edit" after logging in and now the token is not replaced by the users id.

f1mishutka’s picture

Same problem. Downgrading to token 6.x-1.16

Dave Reid’s picture

Status:Needs review» Postponed (maintainer needs more info)

Everyone knows that there is a bug green 'Subscribe' button at the top right of this issue right? Please use it. Thanks.

I have committed a follow-up with http://drupalcode.org/project/token.git/commit/f02c914 that will allow token replacement to still work with arrays but it will also still throw a notice because modules which call with an array still need to be fixed. I will reiterate that it was never supposed to be supported. It only worked by accident.

Please test out the 6.x-1.x-dev release in about 12 hours once it has had the chance to regenerate.

Dave Reid’s picture

Assigned:Unassigned» Dave Reid
Status:Postponed (maintainer needs more info)» Active

Ok installed and enabled Rules and I think I see the problem now. I'm working on it.

Dave Reid’s picture

Status:Active» Fixed

Rules integration has been fixed with http://drupalcode.org/project/token.git/commit/a10367b. I will release a 6.x-1.18 shortly.

Dave Reid’s picture

6.x-1.18 has been released.

chicagomom’s picture

Updating to 6.x-1.18 fixed the issue for me. Thanks Dave!

beasley’s picture

Wow - thanks for fixing this so quickly! Seems to work fine with my Rules now. Fixed before I had chance to investigate it (I wasn't sure if it was Token causing the problem or something else). Thanks again.

tobiberlin’s picture

I do not see any subscribe button... how do I get it??? (I know not the topic but it was mentioned here)

Dave Reid’s picture

tobiberlin’s picture

@Dave thx... it was not green because I already follow... thx much!

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.