Download adaptivetheme-7.x-2.1.tar.gztar.gz 128.47 KB
MD5: 65049438a7460e4d8da8fc561fa99045
SHA-1: 816394cd00705d136a8371717e89d492061dcc18
SHA-256: 11c70b9fb05a22673c35571189338918f0e9165b20cb9db3b7f85612504868d1
Download adaptivetheme-7.x-2.1.zipzip 160.79 KB
MD5: 475ad1784a04395fe8a377b727cec86c
SHA-1: 7e2a206144fece00e8c2d8ae8596b2c235594bae
SHA-256: 9b5d79d81c55840c2feee23093e2ae32cfc663d73b09ad5d3dd4c8ccd8482d33

Release info

Created by: Jeff Burnz
Created on: October 5, 2011 - 12:22
Last updated: October 5, 2011 - 12:26
Core compatibility: 7.x
Release type: Bug fixes

Release notes

Maintenance Release.

Lots of small bug fixes we have unearthed over the past couple of weeks - the initial code has proven to be very stable with mostly small niggly issues with contrib modules and a small number of actual bugs.

Overall I have made the theme cleaner and more consistent especially in regards to the CSS in the sub-theme and big improvements to the admin theme. If you are using or planning to use Gmap or Getlocations modules you need to upgrade. Otherwise if you are not having any issues then you can safely stick with 7.x-2.0, there is nothing critical about this release.

Full backwards compatibility with all 7.x-2.x sub-themes is maintained, you can safely update to this version of the base theme without having to change anything in your sub-themes.

Fixed:

- meta viewport syntax, incorrectly used a semi-colon, changed to comma
- title prefix and suffix vars moved outside of conditional statements, so contextual links always print
- added fix for Gmap and Getlocations modules which choked on max-width 100% for images
- removed grddl profile, no longer required for RDFa
- removed doctype swtich, no longer required for RDFa
- moved print head above hard coded meta tags, so charset is set earlier
- fixed hidden date/time in admin theme
- cleanup CSS in admin theme, add back padding for a browser chrome buffer
- Cleaned up much CSS in the subtheme, better comments and more consistant list styles, removed some hard coded assumptions and old selectors
- Add word-wrap: break-word to all regions and certain wrapper to prevent overflowing content
- converted all line endings back to unix

Dependencies

The selected release is the release that will be used for automated testing. Optional projects are only used for testing.

Required

No required projects

Optional

No optional projects