I have a D7 site setup with Node Gallery and the plupload integration module v7.x-1.7. I can add multiple files to upload into the plupload UI, but when I upload them, the UI returns a warning sign with the message HTTP Error and the files don't upload. Dblog shows the following error:
TYPE access denied
DATE Tuesday, March 31, 2015 – 17:04
USER Anonymous (not verified)
LOCATION https://dev-swva-rtm.gotpantheon.com/node-gallery/json/item/create/1/508...
REFERRER https://dev-swva-rtm.gotpantheon.com/node/5088/upload?render=overlay
MESSAGE node-gallery/json/item/create/1/5088/node_gallery_item/ZmxcRZxrqKIX-K7EboP9I8kN8CttjqM9F61cKG3kSRQ
SEVERITY warning
HOSTNAME 70.169.134.36
This site is hosted at Pantheon, which runs Varnish on their servers. The engineer told me their Varnish config strips all cookies for images, css, js, etc so when the request reaches Drupal, it doesn't have the user's cookie information and therefore can't authenticate them - hence why the user above comes up as Anonymous, even though I submitted the file logged in as admin.
Note that uploading a single image with the gallery item content type works fine. It's just adding multiple images via plupload on the gallery node through the "Upload New Items" tab that generates the error.
Pantheon doesn't allow site owners to edit the Varnish config (I've read other issues where some folks were able to write an exception in their Varnish config to get around a 404 error - https://www.drupal.org/node/2135195#comment-8256165). The Pantheon tech suggested sending the filename over POST instead of GET, but I don't know how to do that (I'm unfortunately more a site-builder/themer than a developer - I know enough PHP to be dangerous!). Is this something that can be patched?
Thank you for any help!