Last updated November 8, 2010. Created on May 26, 2010.
Edited by EugenMayer, pfrenssen, Kami Petersen. Log in to edit this page.



!!! It's important that you use the EXACT (or newer) versions of the modules mentioned HERE !!!
For some modules we require the development versions rather than the recommended versions.

Even though we have quite some dependencies here, most of them are used on 50k+ sites and will probably already be installed in your Drupal installation. jQuery UI and ImageCache will be part of the Drupal 7 core.

  • Jquery UI Dialog: 6.x-1.7 or higher (latest recommended release)
  • ImageCache: 6.x-2.0-beta10 or higher (latest recommended release)
  • Wysiwyg: 6.x-2.1 or higher (latest recommended release)
  • You probably have these installed already, but please verify if you have the right version!

  • jQuery Update: 6.x-2.0-alpha1 or higher (important! we need jQuery 1.3.x, which is in the alpha. Don't use the recommended release of this module (1.1) as it is outdated)
  • jquery_ui: 6.x-1.4 or higher (latest recommended release). The jQuery_UI library must be installed separately, make sure you have jQuery_UI 1.7.x (not 1.6). Refer to this short How-To if you dont know what this is about or how to do this.
  • If you have a NGINX server, please refer to this issue and the solution

I am using jQuery 1.3 and jquery_ui 1.7 for quite a while with drupal and ~ 120 modules now. Its working pretty stable, thats why I used them as the base of this dialog.

Client Browser Dependencies

- Javascript

Browser Compatibility verified (others might work)

  • Firefox 3.x
  • Opera 10.10
  • Google Chrome
  • Safari
  • Internet Explorer 6
  • Internet Explorer 7
  • Internet Explorer 8

Hint: If you experience problems with Opera / Chrome / Safari please review this help:

Looking for support? Visit the forums, or join #drupal-support in IRC.