Closed (fixed)
Project:
Drupal core
Version:
7.x-dev
Component:
taxonomy.module
Priority:
Normal
Category:
Bug report
Assigned:
Unassigned
Issue tags:
Reporter:
Created:
23 Jan 2010 at 14:51 UTC
Updated:
3 Jan 2014 at 01:08 UTC
Jump to comment: Most recent, Most recent file
Comments
Comment #1
dries commentedCommitted to CVS HEAD. Thanks!
Comment #2
dave reidThis is the second culprit of test failures. When I rolled back this patch, the Taxonomy term filters in node forms (TaxonomyNodeFilterTestCase) test passed locally in contrast to 18 fails with current non-rolled-back clean HEAD.
Comment #3
dave reidIn fact the test bot was going to mark this as a fail (http://qa.drupal.org/pifr/test/26456) but I think it was committed before it had the chance to report back.
Comment #4
dave reidReversal of the original patch for now.
Comment #5
catchNode module does module_invoke('taxonomy', 'form_all'). That's evil.
Comment #6
dries commentedRolled back. Sorry about that.
Comment #7
catchComment #8
catchSo the reason tests fail is because admin/content builds a list of every single term in every vocabulary for a select list, and search/node does the same. Both of these are nasty, nasty resource hogs once you go past a certain number of terms. They're also use cases which are much better served by #497804: [meta] Search entities (nodes, terms, etc.) within the administrative interface for admin/content, faceted search instead of advanced search, or views (where you can use autocomplete, or restrict filters to a vocabulary which doesn't have thousands of terms in it).
So here's a patch to just rip that functionality out completely. If that's not acceptable for D7, then we should at least do a COUNT(*) query here and bail out after a certain number, lots of sites use tagging.
Comment #9
moshe weitzman commentedI agree with stripping this feature. Core just can't adequately do what it is trying to do here (show all terms in a select).
Comment #10
dries commentedI support this change as well, and committed the patch to CVS HEAD. It is just not a scalable solution for some sites, and better alternatives are available if necessary.