The new version is not triggering hourly cron in my Drupal 5 site. There is no error message in the log even. Can someone help ?

By the way Cron is working in my Drupal 6 site

Subbu

Comments

Dave Reid’s picture

Version: 5.x-1.2 » 5.x-2.0
Status: Active » Postponed (maintainer needs more info)

Check a couple of things for me:
1. You were sure to run update.php after putting in the new files.
2. You have it set up properly at your admin/settings/site-information page (the one option near the bottom)
3. Double check your site's source code and you see a 'cronCheck' JavaScript variable in the <head> section.
4. Double check that the poormanscron.js files is included in your site's source code in the <head> section.

Dave Reid’s picture

I also fixed a bug in the upgrade path that didn't properly bring your cron interval to the new setting. So double check your admin/settings/site-information page and make sure 'Automatically run cron' isn't set to 'Never'.

shariharan’s picture

Thanks for the reply. I have set the cron to run at every hour. I did run Update.php. I will check 3 & 4. I forgot to mention that cron was running fine till the current upgrade.

Update : I see the js file, but the cronCheck variable is missing on the head section

kiamlaluno’s picture

@subru77: What is about the point #4? Is the file poormanscron.js being loaded?

Dave Reid’s picture

@subru77: Can you provide link to your site to help us debug? If you don't want to post it here, you can use my contact form (link my name and use the 'Contact' tab). In the meantime can you also try on a different (perferrably core) theme to see if its theme related?

@kiamlaluno: He does say in #3 that he sees the js file being included.

shariharan’s picture

Sorry for the delay.. I was away for a while.

The site is in a private LAN. So I am not able to share it with you. I changed the theme. But I am not seeing the cronCheck variable. I am pasting the HTML head code below


<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
  "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd"> 
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="xx" lang="xx"> 
  <head> 
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> 
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> 
 
      <!-- Additional IE/Win specific style sheet (Conditional Comments) --> 
      <!--[if IE]>
      <style type="text/css" media="all">@import "/sites/all/modules/jstools/tabs/tabs-ie.css";</style>
      <![endif]--> 
    
<link rel="shortcut icon" href="/misc/favicon.ico" type="image/x-icon" /> 
    <title>C.R.U.I.S.E. Connections</title> 
    <style type="text/css" media="all">@import "/sites/all/modules/admin_menu/admin_menu.css";</style> 
<style type="text/css" media="all">@import "/files/css/c1380aea63b7cdd8a003c947b1dfaee6.css";</style> 
    <script type="text/javascript" src="/misc/jquery.js"></script> 
<script type="text/javascript" src="/misc/drupal.js"></script> 
<script type="text/javascript" defer="defer" src="/sites/all/modules/admin_menu/admin_menu.js"></script> 
<script type="text/javascript" src="/sites/all/modules/jquery_update/compat.js"></script> 
<script type="text/javascript" src="/sites/all/modules/jstools/jstools.js"></script> 
<script type="text/javascript" src="/sites/all/modules/jstools/tabs/jquery.tabs.pack.js"></script> 
<script type="text/javascript" src="/sites/all/modules/jstools/tabs/tabs.js"></script> 
<script type="text/javascript" src="/sites/all/modules/lightbox2/js/auto_image_handling.js"></script> 
<script type="text/javascript" src="/sites/all/modules/lightbox2/js/lightbox.js"></script> 
<script type="text/javascript" src="/sites/all/modules/poormanscron/poormanscron.js"></script> 
<script type="text/javascript" src="/sites/all/modules/panels/js/panels.js"></script> 
<script type="text/javascript" src="/misc/autocomplete.js"></script> 
<script type="text/javascript">Drupal.extend({ settings: { "admin_menu": { "margin_top": 1 },  "tabs": { "slide": false, "fade": false, "speed": "fast", "auto_height": false, "next_text": "next", "previous_text": "previous" }, "lightbox2": { "rtl": false, "file_path": "/(\\w\\w/)files", "base_path": "/", "default_image": "/sites/all/modules/lightbox2/images/brokenimage.jpg", "border_size": "10", "font_color": "000", "box_color": "fff", "top_position": "", "overlay_opacity": "0.6", "overlay_color": "000", "disable_close_click": true, "resize_sequence": "0", "resize_speed": 400, "fade_in_speed": 400, "slide_down_speed": 600, "use_alt_layout": 1, "disable_resize": 1, "disable_zoom": 0, "force_show_nav": 0, "loop_items": 0, "node_link_text": "", "node_link_target": 0, "image_count": "Image !current of !total", "page_count": "Page !current of !total", "video_count": "Video !current of !total", "lite_press_x_close": "press \x3ca href=\"#\" onclick=\"hideLightbox(); return FALSE;\"\x3e\x3ckbd\x3ex\x3c/kbd\x3e\x3c/a\x3e to close", "enable_login": false, "enable_contact": false, "keys_close": "c x 27", "keys_previous": "p 37", "keys_next": "n 39", "keys_zoom": "z", "keys_play_pause": "32", "display_image_size": "", "image_node_sizes": "()", "trigger_lightbox_classes": "", "trigger_lightbox_group_classes": "img.inline,img.ImageFrame_image,img.ImageFrame_none", "trigger_slideshow_classes": "", "trigger_lightframe_classes": "", "trigger_lightframe_group_classes": "", "custom_class_handler": 0, "custom_trigger_classes": "", "disable_for_gallery_lists": 0, "disable_for_acidfree_gallery_lists": true, "enable_acidfree_videos": false, "slideshow_interval": 5000, "slideshow_automatic_start": true, "slideshow_automatic_exit": true, "show_play_pause": true, "pause_on_next_click": false, "pause_on_previous_click": true, "loop_slides": false, "iframe_width": "800", "iframe_height": "600", "iframe_border": 1, "enable_video": 0 }, "cron": { "basePath": "/poormanscron", "runNext": 1264643454 } } });</script> 
    <style type="text/css" media="print">@import "/themes/garland/print.css";</style> 
    <!--[if lt IE 7]>
    <style type="text/css" media="all">@import "/themes/garland/fix-ie.css";</style>
    <![endif]--> 
  </head> 

Thanks again guys for helping out

Dave Reid’s picture

"cron": { "basePath": "/poormanscron", "runNext": 1264643454 } is what we were looking for, so it looks like it should be working properly. On your admin/logs/watchdog page, you haven't seen any 'cron' messages saying 'Cron run completed.'?

Also double your browser's JavaScript console while browsing your site. There may be some other JavaScript causing an error. When that happens usually no other JavaScript get executed, so that could be preventing it from running.

zcferres’s picture

I am having the same issues as him with the same version. Mine also has the js include, the site information config is proper, the variables are added, and update has been run.

Any other ideas?

Dave Reid’s picture

@zcferres See the questions I asked in #7. Same applies for you too. :)

treksler’s picture

Status: Postponed (maintainer needs more info) » Active

same thing happens here

this does not work ... jquery update may be the culprit

$('body:not(.cron-check-processed)', context).addClass('cron-check-processed').each(function() { ... }

all the variables look fine and this would work but it never gets this far

if (Math.round(new Date().getTime() / 1000.0) >= Drupal.settings.cron.runNext) { ... }

however, this does not seem to do anything either

$.get(Drupal.settings.cron.basePath + '/run-cron-check');

the Safari error console contains "Failed to load resource: cancelled" even though the path looks ok and can be accessed manually

shariharan’s picture

Thanks all, We migrated to Drupal 6. So the problem is fixed for me. I am not sure if 5.x still has the problem.

lsabug’s picture

Is this still an issue or has it been fixed with 2.1? I'm concerned about upgrading my drupal 5 site and upgrading to 6x isn't an option at this stage.
Thanks.

treksler’s picture

this is an issue in 2.1 in Drupal 5.x .. I am stuck with using 1.2 :(

TechNikh’s picture

Version: 5.x-2.0 » 5.x-2.1
Priority: Normal » Major

I have the same issue in 5.x-2.1.
I don't see any javascript errors in firebug console