It took me a couple hours to figure out what was wrong with my aegir setup (turns out I needed to add Default:aegir !requiretty to my sudoexec). It would have only taken me a minute or two if _provision_apache_restart_apache included the output of the drupal_shell_exec in the error message.

  $return = drush_shell_exec(escapeshellcmd(drush_get_option('restart_cmd')));
  if (!$return) {
    $error_msg = implode('; ', drush_shell_exec_output());
    if ($cause_error) {
      return drush_set_error('PROVISION_WEB_RESTART_FAILED', dt("Web server could not be restarted. Changes might not be available until this has been done.") . " $error_msg");
    }
    else {
      drush_log(dt("Web server could not be restarted. Changes might not be available until this has been done.") . " $error_msg", "warning");
    }
  }
 

Comments

anarcat’s picture

Status: Needs review » Fixed

Improved fix pushed in git as e9acdb5.

Status: Fixed » Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

  • Commit 4ae1d0c on debian, dev-dns, dev-envobject, dev-koumbit, dev-log_directory, dev-migrate_aliases, dev-multiserver-install, dev-newhooks, dev-nginx, dev-platform_management, dev-ports, dev-purgebackup, dev-restore, dev-services, dev-simplerinstaller, dev-site_rename, dev-ssl, dev_716166_apache_conf, dev_dns, dev_server_verify, prod-koumbit, dev-ssl-ip-allocation-refactor, dev-1205458-move_sites_out_of_platforms, 7.x-3.x, dev-subdir-multiserver, 6.x-2.x-backports, dev-helmo-3.x by anarcat:
    #654610 - output the apache error on failures to restart