It took me a couple hours to figure out what was wrong with my aegir setup (turns out I needed to add Default:aegir !requiretty to my sudoexec). It would have only taken me a minute or two if _provision_apache_restart_apache included the output of the drupal_shell_exec in the error message.
$return = drush_shell_exec(escapeshellcmd(drush_get_option('restart_cmd')));
if (!$return) {
$error_msg = implode('; ', drush_shell_exec_output());
if ($cause_error) {
return drush_set_error('PROVISION_WEB_RESTART_FAILED', dt("Web server could not be restarted. Changes might not be available until this has been done.") . " $error_msg");
}
else {
drush_log(dt("Web server could not be restarted. Changes might not be available until this has been done.") . " $error_msg", "warning");
}
}
Comments
Comment #1
anarcat commentedImproved fix pushed in git as e9acdb5.