Error message appears when enabling the module on a standard (umami demo) drupal site:
Unable to install Elasticsearch - Search API Example due to unmet dependencies: search_api.index.example_general (search_api.server.elastic)

The search_api.server.elastic config file is not included in the install directory, if it's not available in existing configuration - the module install will fail

Command icon Show commands

Start within a Git clone of the project using the version control instructions.

Or, if you do not have SSH keys set up on git.drupalcode.org:

Comments

robindh created an issue. See original summary.

robindh’s picture

Error is correct, search_api server + elasticsearch cluster config can't be committed since they contain variable info, that will differ per project. Workaround: document the setup process in the README.md of the example module. Search api server + elasticsearch cluster needs to be created manually before enabling the module.

robindh’s picture

Component: Code » Documentation

robindh’s picture

Status: Active » Needs review

jOpdebeeck made their first commit to this issue’s fork.

jopdebeeck’s picture

Status: Needs review » Reviewed & tested by the community

  • jOpdebeeck committed 7608aa1 on 2.0.x authored by robindh
    Issue #3324033 by robindh, jOpdebeeck: Unmet dependency in example...
jopdebeeck’s picture

Status: Reviewed & tested by the community » Fixed

Status: Fixed » Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.