
Problem 1
- Installation request for drupal/inline_entity_form (locked at 1.0.0-rc3, required as ^1.0@RC) -> satisfiable by drupal/inline_entity_form[1.0.0-rc3].
- Installation request for drupal/commerce_paypal 1.0-beta7 -> satisfiable by drupal/commerce_paypal[1.0.0-beta7].
- drupal/commerce_paypal 1.0.0-beta7 requires drupal/commerce ^2.19 -> satisfiable by drupal/commerce[2.x-dev, 2.19.0].
- drupal/commerce 2.x-dev requires drupal/inline_entity_form ^1.0-rc6 -> satisfiable by drupal/inline_entity_form[1.0.0-rc6].
- drupal/commerce 2.19.0 requires drupal/inline_entity_form ^1.0-rc6 -> satisfiable by drupal/inline_entity_form[1.0.0-rc6].
- Conclusion: don't install drupal/inline_entity_form 1.0.0-rc6
Site breakage Error at /admin/reports/updates
Warning: include(/var/www/html/vendor/composer/../../core/lib/Drupal/Core/DrupalKernel.php): failed to open stream: No such file or directory in /var/www/html/vendor/composer/ClassLoader.php on line 444
Warning: include(): Failed opening '/var/www/html/vendor/composer/../../core/lib/Drupal/Core/DrupalKernel.php' for inclusion (include_path='/var/www/html/vendor/pear/archive_tar:/var/www/html/vendor/pear/console_getopt:/var/www/html/vendor/pear/pear-core-minimal/src:/var/www/html/vendor/pear/pear_exception:.:/usr/share/php') in /var/www/html/vendor/composer/ClassLoader.php on line 444
Fatal error: Uncaught Error: Class 'Drupal\Core\DrupalKernel' not found in /var/www/html/index.php:16 Stack trace: #0 {main} thrown in /var/www/html/index.php on line 16
Comments
Comment #2
jsacksick commentedThat error seems completely unrelated to PayPal (as the module wasn't updated because of a conflict in your composer.json requirements).
Please read https://www.drupal.org/docs/updating-drupal/update-modules-and-themes-us... for instructions on how to properly update modules.
I successfully updated to 1.0-beta7 on several projects.
Comment #3
jsacksick commentedNote that the latest version requires the latest Drupal Commerce version (2.19).
Comment #4
the_glitch commentedAh yeh. I'm having troubles getting commerce from v2.8 to 2.9