When disabling and re-enabling the module, the existing configs do throw an error and make re-installation impossible.

Decide weather to make the config optional (using the optional folder instead of the install folder), or delete the config from the database in an uninstall hook.

I vote for both ;) Or is there any need for the entity browser to exist on?

Comments

ytsurk created an issue. See original summary.

ytsurk’s picture

  • ytsurk committed b3b34cf on 8.x-1.x
    Issue #3096053 by ytsurk: Disabling and enabling the module again
    
ytsurk’s picture

Status: Active » Fixed

I left the config non-optional for now, but delete the view, the entitybrowsers, the image style and the generated files.

Status: Fixed » Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.