Closed (duplicate)
Project:
Drupal core
Version:
8.7.x-dev
Component:
phpunit
Priority:
Normal
Category:
Bug report
Assigned:
Unassigned
Issue tags:
Reporter:
Created:
18 Feb 2019 at 08:46 UTC
Updated:
8 May 2019 at 18:34 UTC
Jump to comment: Most recent
Comments
Comment #2
gillesbailleux@ecvandenberg: having the same issue when typing
composer updateon a fresh D8 install without any module nor theme installed (even the core modules have not been configured yet). This means the error is not related to this CKEditor Anchor Link - For Drupal 8 module.Comment #3
ecvandenberg commentedMere coincidence obviously. I'm sorry for not checking.
Comment #4
pasqualle$ composer depends phpunit/phpunit-mock-objects
phpunit/phpunit 6.5.14 requires phpunit/phpunit-mock-objects (^5.0.9)
It seems the only way forward is #2950132: Support PHPUnit 7 optionally in Drupal 8, while keeping support for ^6.5
Comment #5
pasqualleComment #6
oriol_e9gI think this can be considered duplicated by #2950132: Support PHPUnit 7 optionally in Drupal 8, while keeping support for ^6.5.
Comment #7
chanchal2002 commentedI am using Drupal 8.6.x and getting same message.
Comment #8
slefevre@ccad.edu commentedI've been getting the same message for months now when I run `composer update`/`require` etc.
Comment #9
sami-an commentedI've been getting the same message
Package phpunit/phpunit-mock-objects is abandoned, you should avoid using it. No replacement was suggested.
Comment #10
thirstysix commentedI am getting the same issue Drupal 8.6.14 in PHP 7.3.3.
PHPUnit 6 is no longer supported.
https://phpunit.de/getting-started/phpunit-8.html
composer require --dev phpunit/phpunit ^8
but, I am getting the below issue
Problem 1
- webflo/drupal-core-require-dev 8.6.14 requires phpunit/phpunit ^4.8.35 || ^6.5 -> satisfiable by phpunit/phpunit[4.8.35, 4.8.36, 6.5.0, 6.5.1, 6.5.10, 6.5.11, 6.5.12, 6.5.13, 6.5.14, 6.5.2, 6.5.3, 6.5.4, 6.5.5, 6.5.6, 6.5.7, 6.5.8, 6.5.9] but these conflict with your requirements or minimum-stability.
- webflo/drupal-core-require-dev 8.6.14 requires phpunit/phpunit ^4.8.35 || ^6.5 -> satisfiable by phpunit/phpunit[4.8.35, 4.8.36, 6.5.0, 6.5.1, 6.5.10, 6.5.11, 6.5.12, 6.5.13, 6.5.14, 6.5.2, 6.5.3, 6.5.4, 6.5.5, 6.5.6, 6.5.7, 6.5.8, 6.5.9] but these conflict with your requirements or minimum-stability.
- webflo/drupal-core-require-dev 8.6.14 requires phpunit/phpunit ^4.8.35 || ^6.5 -> satisfiable by phpunit/phpunit[4.8.35, 4.8.36, 6.5.0, 6.5.1, 6.5.10, 6.5.11, 6.5.12, 6.5.13, 6.5.14, 6.5.2, 6.5.3, 6.5.4, 6.5.5, 6.5.6, 6.5.7, 6.5.8, 6.5.9] but these conflict with your requirements or minimum-stability.
- Installation request for webflo/drupal-core-require-dev (locked at 8.6.14, required as ^8.6.0) -> satisfiable by webflo/drupal-core-require-dev[8.6.14].
It's accepts only 4.8.35 to 6.5.9. Any Idea?
Thanks in Advance.
Comment #11
71ranger commentedHi i did a fresh Drupal8 install version 8.2.7 (web hosted) and upgraded to 8.6.15 this message also appeared
Package phpunit/phpunit-mock-objects is abandoned, you should avoid using it. No replacement was suggested.
Kind Regards
Brian
Comment #12
amarphule commentedI am using Drupal-8.6.15 while running
$ composer installon a drupal project gives message.
Comment #13
xjm#3039275: phpunit-mock-objects is marked as "abandoned" when composer.lock is rebuilt is the issue for this. We don't need additional reports of sites being affected; it will happen any time the composer.lock is rebuilt from now on. Thanks!