We are on an NGINX server running PHP 7.1. After updating from 1.61 to 2.3 the website crashes with below error:

The website encountered an unexpected error. Please try again later.
ArgumentCountError: Too few arguments to function Drupal\permissions_by_term\Service\AccessStorage::__construct(), 3 passed in /docroot/core/lib/Drupal/Component/DependencyInjection/Container.php on line 270 and exactly 5 expected in Drupal\permissions_by_term\Service\AccessStorage->__construct() (line 76 of modules/contrib/permissions_by_term/src/Service/AccessStorage.php).

As of the release not this should not happen on PHP 7.1. Anything we are missing?

Comments

criscom created an issue. See original summary.

criscom’s picture

Title: Updating to permission_by_terms to 2.3 fails with PHP 7.1 » Updating permission_by_terms to 2.3 fails with PHP 7.1
criscom’s picture

the problem comes from domain module's DomainAliasLoader.php function public function loadMultiple($ids = NULL, $reset = FALSE) {

above function needs to be changed to public function loadMultiple(array $ids = NULL, $reset = FALSE) {

criscom’s picture

criscom’s picture

The patch was actually conceived by kevinpfeifer. I have just created it from his ideas for the project page.

agentrickard’s picture

Thanks.

agentrickard’s picture

agentrickard’s picture

  • agentrickard committed 97f3dec on 8.x-1.x authored by criscom
    Issue #3008970 by criscom, kevin.pfeifer: Updating permission_by_terms...
agentrickard’s picture

Status: Active » Fixed

Yup, this was fixed in all other instances of loadMultiple(), just not this one.

Status: Fixed » Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.