Closed (fixed)
Project:
Drupal core
Version:
8.3.x-dev
Component:
cache system
Priority:
Critical
Category:
Bug report
Assigned:
Unassigned
Issue tags:
Reporter:
Created:
27 Jan 2017 at 09:41 UTC
Updated:
16 Feb 2017 at 12:16 UTC
Jump to comment: Most recent, Most recent file
Comments
Comment #2
alexpottComment #3
alexpottThis could easily be a timing issue...
Comment #4
alexpottLet's add some info to the assertion message to help us.
Comment #5
pwolanin commentedSporadic fail here: https://www.drupal.org/pift-ci-job/583247
Comment #9
catchCommitted the better assertion message to aid debugging.
Comment #10
tacituseu commentedhttps://www.drupal.org/pift-ci-job/584350
$difference = $cache_item->expire - (int) $cache_item->created; // (= 3594)Comment #11
dawehnerWe could increase this offset from 5 to 15 seconds. The actual page cache system is quite unit tested in
\Drupal\page_cache\StackMiddleware\PageCacheso we don't really necessarily loose a lot of test coverage with doing so. Increasing the number to 15 seconds would dramatically decrease the probability for random failures.Comment #12
xjmAdding the HEAD failure to the summary to demonstrate it's not just an issue with a patch.
Comment #13
tacituseu commentedhttps://www.drupal.org/pift-ci-job/584500
$difference = 3594;Comment #14
dawehner@tacituseu
I guess 6 seems basically the maximum we get in random test failures, so maybe increasing the different to 10 would already be enough?
Comment #15
tacituseu commentedCouldn't find more instances.
Comment #16
dawehner10 seconds work for me
Comment #18
tacituseu commentedPatch against HEAD this time ;)
Comment #20
tacituseu commentedJust a re-roll so back to RTBC per #16.
BTW in https://www.drupal.org/pift-ci-job/585026 patch failed to apply, yet all the tests ran anyway, seen it a couple of times now.
Also reasoning behind 10 seconds is: 6-7 is extreme case and doesn't occur often, caused by high concurrency on testbot, if it gets any slower would be good to know/trip anyway.
Comment #21
tacituseu commentedhttps://www.drupal.org/pift-ci-job/584529
The cache entry expiry time uses the cache_ttl_4xx setting. Expire: 1485653810 Created: 1485650215.513
$difference = 3595;Could someone re-trigger default branch for 8.4.x-dev ? It's stalling issues for more than a day now.
https://www.drupal.org/node/3060/qa
Comment #24
catchCommitted/pushed to 8.4.x and 8.3.x.
Doesn't apply to 8.2.x but since it's test-only, I think we can leave this at 8.3.x.
Comment #25
tacituseu commented#15 has patch that applies to 8.2.x
Comment #26
xjmComment #28
tacituseu commentedWell..
https://www.drupal.org/pift-ci-job/600319
$difference = 3590