The first alpha for Drush 9.x was released 4 weeks ago. Currently, if Drush 9.x is used, provision will fail with the error: "Error: Drush !version is not supported". This is not a duplicate of #2554029: Error: Drush !version is not supported, although they both likely involve similar or related code blocks re: version detection/validation of Drush.
The fix to this is a simple additional case in the select statement at line 87 of platform/drupal/install_7.inc to add the substr(drush_core_version(), 0, 1) = 9 case to fall through to the Drush 8.x case that falls through to the Drush 7.x case.
I'll revise this shortly with a patch against dev, 7.x-3.x.
Comments
Comment #2
JamesAn commentedAmended tag and branch head targets for this issue's patches. 7.x-4.x is a dev branch without yet much activity; i.e. there's no practical point in patching against it.
Comment #3
JamesAn commentedHere's the patch against 7.x-3.x. Applying this patch to either 7.x-3.x or 7.x-3.4 works and in both cases, the patched code can successfully be used to execute a clean hostmaster-install and run various drush-initiated provision commands and hostmaster-initiated tasks including verifying all initial Aegir entities and enabling the hosting daemon along with its backend systemd service.
I don't notice any unexpected side effects, although I haven't been thorough at all. Can someone corroborate this one-liner feature add?
Comment #4
JamesAn commentedCorrecting the dev version in which this issue is being addressed: 7.x-3.x.
Comment #6
helmo commentedI haven't had a chance to test Drush 9 but this makes perfect sence... committed. Thanks.
Comment #7
colanAdded a missing "#" in an issue link in the description.