We have uncovered a few bugs with PostgreSQL in the search module, so today I installed a PostgreSQL local site and ran the Search module tests.

After 10 of 23 tests had completed, I stopped because there were so many failures. I'm filing this issue to (hopefully) fix these issues and get the tests to pass. I guess I'll make this a meta-issue and file separate issues for the individual problems, and patch them there. Adding in a couple that have already been filed for now.

Current results I'm seeing:

Processed test 10 of 23 - Search language selection.
Overall results: 690 passes, 41 fails, 0 exceptions, 203 debug messages

Search language selection: 43 passes, 0 fails, 0 exceptions, 14 debug messages
Keywords and conditions: 28 passes, 0 fails, 0 exceptions, 7 debug messages
Search excerpt extraction: 28 passes, 0 fails, 0 exceptions
Search engine phrase queries: 21 passes, 4 fails, 0 exceptions, 6 debug messages
Embedded forms: 27 passes, 6 fails, 0 exceptions, 8 debug messages
Config settings form: 265 passes, 5 fails, 0 exceptions, 69 debug messages
Comment Search tests: 175 passes, 20 fails, 0 exceptions, 67 debug messages
Comment count toggle: 28 passes, 3 fails, 0 exceptions, 10 debug messages
Block availability: 44 passes, 0 fails, 0 exceptions, 12 debug messages
Advanced search form: 31 passes, 3 fails, 0 exceptions, 10 debug messages

Comments

jhodgdon’s picture

Update:
- #2087169: NodeSearch::updateIndex does not include order by column in select actually has been fixed in 8 so is not relevant here.
- I made a patch for #2158339: Search results page broken on PostgreSQL, and so far the Search tests are passing with this patch.

I will wait until the rest of the tests are done running and then either close this as fixed or file more issues.

jhodgdon’s picture

OK, with that patch, there are just two tests failing. Filed issues:
#2195907: Search ranking for number of views fails in PostgreSQL
#2195915: Cannot save text filter config using PostgreSQL if Comment is enabled [blocks installation!]

(both are marked with this one as "parent").

jhodgdon’s picture

As a note, #2195915 has been determined to actually be a problem in comment.module. It is not really a search module bug at all.

bzrudi71’s picture

Since #2195907: Search ranking for number of views fails in PostgreSQL is in and as per #4 #2195915: Cannot save text filter config using PostgreSQL if Comment is enabled [blocks installation!] is not really related, can we decouple #2195915 from this meta an mark as fixed? :-)

jhodgdon’s picture

Well, that second issue is making it so that we cannot run the search.module tests under PostgreSQL, whether the root cause is in search.module or comment.module or whatever, so I think it may be useful to keep this issue open until it is actually fixed? Besides that second issue has this one as its parent, at least at the moment.

jhodgdon’s picture

Status: Active » Fixed

All the sub-issues are resolved now. High-5!

Status: Fixed » Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.