It is now in views module..should be in views_ui and since it tests RearrangeFilter it should be named as such
The last submitted patch, drupal-move_ViewsUITest-2012170-1.patch, failed testing.
#1: drupal-move_ViewsUITest-2012170-1.patch queued for re-testing.
Looks good, noticed this yesterday when working on the change notice for PHPUnit, patch looks good and test is correctly listed on qa.d.o.
I think we originally planned for more tests to go into this unit test. But then we moved that method to RearrangeFilter and the rest is history. I guess this is good how it is. Not sure it it makes sense to still have a unit test class that tests lots of random methods like this? Seems like if we created a new one every time we would have alot of test classes with not alot in?
thats what we should do (and already do for Core and Component). a test class per file in the same location, so you know exactly where to find it
Yeah, how this is now is totally fine, and it's not like PHPUnit is slow :)
Committed 081a59c and pushed to 8.x. Thanks!
Automatically closed -- issue fixed for 2 weeks with no activity.
Drupal is a registered trademark of Dries Buytaert.