Posted by xjm


The test filter plugin in core/modules/filter/tests/filter_test/lib/Drupal/filter_test/Plugin/Filter/FilterTestReplace.php uses the wrong case for getPluginId():

    $text[] = 'Filter: ' . $this->getLabel() . ' (' . $this->getPluginID() . ')';

While function names are (apparently) not case sensitive in PHP (@alexpott looked this up) and "Id" is a different word from "ID", we should nonetheless use the same case as the method defined on PluginBase.

Proposed resolution

Rename FilterTestReplace::getPluginID() to getPluginId().

#2 filters-method-name-getPluginId-7461444-2.patch894 bytesbrentaar
PASSED: [[SimpleTest]]: [MySQL] 55,673 pass(es). View
Members fund testing for the Drupal project. Drupal Association Learn more


brentaar’s picture

Assigned: Unassigned » brentaar
brentaar’s picture

Status: Active » Needs review
894 bytes
PASSED: [[SimpleTest]]: [MySQL] 55,673 pass(es). View
brentaar’s picture

Assigned: brentaar » Unassigned
munizjor’s picture

Everything looks good.

xjm’s picture

Status: Needs review » Reviewed & tested by the community

Thanks @brentaar!

alexpott’s picture

Status: Reviewed & tested by the community » Fixed

Committed 4074668 and pushed to 8.x. Thanks!

Automatically closed -- issue fixed for 2 weeks with no activity.

Anonymous’s picture

Issue summary: View changes

Removing myself from the author field to unfollow the issue. --xjm