Files: 
CommentFileSizeAuthor
#14 rename-views-method-get_offset-to-getoffset-2002968-13.patch3.34 KBzhgenti
PASSED: [[SimpleTest]]: [MySQL] 55,848 pass(es). View
#7 rename-views-method-get_offset-to-getoffset-2002968-6.patch3.6 KBzhgenti
PASSED: [[SimpleTest]]: [MySQL] 55,955 pass(es). View
#4 rename-views-method-get_offset-to-getoffset-2002968-7451484.patch3.33 KBzhgenti
FAILED: [[SimpleTest]]: [MySQL] Repository checkout: failed to checkout from [git://git.drupal.org/project/drupal.git]. View
#2 rename-views-method-get_offset-to-getoffset-2002968-7449220.patch3.33 KBzhgenti
FAILED: [[SimpleTest]]: [MySQL] 55,848 pass(es), 1 fail(s), and 0 exception(s). View

Comments

zhgenti’s picture

Assigned: Unassigned » zhgenti
zhgenti’s picture

Status: Active » Needs review
FileSize
3.33 KB
FAILED: [[SimpleTest]]: [MySQL] 55,848 pass(es), 1 fail(s), and 0 exception(s). View

Status: Needs review » Needs work
zhgenti’s picture

Status: Needs work » Needs review
FileSize
3.33 KB
FAILED: [[SimpleTest]]: [MySQL] Repository checkout: failed to checkout from [git://git.drupal.org/project/drupal.git]. View

Status: Needs review » Needs work
oenie’s picture

All occurences replaced; correct the issue below.

+++ b/core/modules/views/lib/Drupal/views/Plugin/views/pager/PagerPluginBase.phpundefined
@@ -87,7 +87,7 @@ function set_items_per_page($items) {
+  function getOffset() {

Add public access modifier in front of the function to adhere to the new OOP standards.

zhgenti’s picture

Status: Needs work » Needs review
FileSize
3.6 KB
PASSED: [[SimpleTest]]: [MySQL] 55,955 pass(es). View

Issue in #6 addressed

Status: Needs review » Needs work
Issue tags: -Novice, -VDC

The last submitted patch, rename-views-method-get_offset-to-getoffset-2002968-6.patch, failed testing.

zhgenti’s picture

Status: Needs work » Needs review
Issue tags: +Novice, +VDC
oenie’s picture

Is there a specific reason why you have put an access modifier in front of set_items_per_page ?
Because that is part of a different rename, and might give clashes with #2003282: Rename Views method set_items_per_page() to setItemsPerPage()

dawehner’s picture

Status: Needs review » Needs work

So clearly needs work :(

zhgenti’s picture

Isn't it what you suggested in comment #6? I probably misunderstood something :(

heddn’s picture

function getOffset() should be public. Also, I noticed that when you re-rolled the patch in #6 you rolled and interdiff, not a diff from HEAD.

zhgenti’s picture

Status: Needs work » Needs review
FileSize
3.34 KB
PASSED: [[SimpleTest]]: [MySQL] 55,848 pass(es). View

What a shame ( I looked at the different function in the comment 6... Should be fine now, also rolled over HEAD

dawehner’s picture

Status: Needs review » Reviewed & tested by the community

Perfect.

webchick’s picture

Title: Rename Views method get_offset() to getOffset() » Change notice: Rename Views method get_offset() to getOffset()
Project: Drupal core » Views
Version: 8.x-dev » 8.x-3.x-dev
Component: views.module » Code
Status: Reviewed & tested by the community » Active
Issue tags: +Needs change record

Committed and pushed to 8.x. Thanks!

Moving to Views for the change notice.

xjm’s picture

Title: Change notice: Rename Views method get_offset() to getOffset() » Rename Views method get_offset() to getOffset()
Project: Views » Drupal core
Version: 8.x-3.x-dev » 8.x-dev
Component: Code » views.module
Assigned: zhgenti » Unassigned
Issue tags: -Needs change record
xjm’s picture

Status: Active » Fixed

Oops.

Automatically closed -- issue fixed for 2 weeks with no activity.