HaLe Mail is an email marketing platform using state of the art technology which permits you to send emails to your different email databases.
This 100% online tool combines a high level of performance and penetration with an enormous ease of use. Thanks to its advanced statistics, you will
know everything about your emailing campaign, which allows you to further develop and finetune your emailing strategies no matter where you are located in the world!

The HaLe Mail API module is needed to allow you to take advantage of the API made available for HaLe Mail.
This module is required to use the HaLe Mail 3.0 (Un)Subscribe module.

Sandbox page:

git clone --recursive --branch master Lajfi@git.drupal.org:sandbox/Lajfi/1840524.git

Drupal version => 7


vineet.osscube’s picture

Status:Needs review» Needs work

Manual Review:
1) // $Id: $ is no longer required. So you can remove this.
2) Do not use t() function into .install file. get_t() exists to support localisation for code that might run during the installation phase.
3) hook_perm not work into d7 it replace with hook_permission in D7.

I suggest you to take a look at this page:

Here you can check source code whether it meets drupal coding standards or not, and advise you what to change in your code. You can repeat review after your commits, and can fix those errors.

Lajfi’s picture

Status:Needs work» Needs review


i have tackled the points you mentioned


can you please review?


sirup’s picture

Status:Needs review» Closed (won't fix)

As mentioned in http://drupal.org/node/1840698: Please consider to include this module inside the other one.

In any case: You are only allowed to have one project in the "project applications" list at the same time! Please add a hint to the api module from your other issue.

sirup’s picture

for reference, please see point 1.3 in http://drupal.org/node/1587704