The doc block for system_authorized_init() says, in part,

<?php
/**
 * ...
 * This function sets up all the necessary $_SESSION variables, then returns
 * the full path to authorize.php so the caller can redirect to authorize.php.
 * ...
 * @return
 *   Nothing, this function just initializes variables in the user's session.
?>

There is also a typo ("one" instead of "once") in the @callback line.

I will submit a patch as soon as I have an issue number.

Files: 
CommentFileSizeAuthor
#1 system-authorized-init-1827200.patch2.42 KBbenjifisher
PASSED: [[SimpleTest]]: [MySQL] 46,332 pass(es).
[ View ]

Comments

benjifisher’s picture

Status:Active» Needs review
StatusFileSize
new2.42 KB
PASSED: [[SimpleTest]]: [MySQL] 46,332 pass(es).
[ View ]

The attached patch corrects the documentation. I also added two @code examples and an @see reference.

Status:Needs review» Needs work

The last submitted patch, system-authorized-init-1827200.patch, failed testing.

jhodgdon’s picture

Assigned:Unassigned» jhodgdon
Status:Needs work» Reviewed & tested by the community

The test failure is unrelated -- I'll click re-test in a sec...

Anyway, thanks for the report and the patch! It looks good and I'll get it committed next week (commits of non-essential patches are currently postponed due to a big Views sprint that's going on right now).

jhodgdon’s picture

#1: system-authorized-init-1827200.patch queued for re-testing.

dww’s picture

+1. Looks good to me, too. Thanks!

jhodgdon’s picture

Assigned:jhodgdon» Unassigned
Status:Reviewed & tested by the community» Fixed

Thanks again! Committed to 8.x and 7.x.

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.