I've noticed that VirtualEarth layers don't always appear in Firefox. In fact I still haven't managed to make them appear even once in Firefox, after a quick search, I got here: http://trac.osgeo.org/openlayers/ticket/3518 wich in turn led me to find that the use of VirtualEarth got deprecated in OpenLayers: https://github.com/openlayers/openlayers/commit/3d0d2cbc
So it seems support to Layer.Bing is the way to go.

CommentFileSizeAuthor
#3 0001-Enable-Microsoft-Bing-layers.patch5.96 KBPol
Members fund testing for the Drupal project. Drupal Association Learn more

Comments

JaceRider’s picture

Category: feature » bug
Priority: Normal » Major

After several attempt I am also unable to get Virtual Earth to display in Firefox.

kricklin’s picture

I'm experiencing similar behavior with Virtual Earth layers as very often I only see the "bing" logo and white space where the map should be. Must refresh the page to see the map.

Pol’s picture

Patch to enable Microsoft Bing layers.

For testing purpose ONLY, you can use the key: AqTGBsziZHIJYYxgivLBf0hVdrAk9mWO5cQcb8Yux8sW5M8c8opEC2lZqKR1ZZXf

Pol’s picture

Status: Active » Needs review

Status: Needs review » Needs work

The last submitted patch, 0001-Enable-Microsoft-Bing-layers.patch, failed testing.

cesareaugusto’s picture

I exparience the same issue. Now and then maps do not display on FF. How to fix this?

Patroclas’s picture

This is not working for me either - after changing all my maps to use Bing, I discovered that they are not displaying in FF. This is quite a problem since Google Satellite imagery is very poor for my location but Bing has very good coverage.

Anyone have a fix please?

Pol’s picture

Assigned: Unassigned » Pol

I'll handle it as I have a bit more time.

Pol’s picture

Status: Needs work » Fixed

Fixed!

Status: Fixed » Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.