I'm currently running 7.12, with the Omega theme as my presentational theme, and Rubik as my admin theme. I like the combination of using Rubik alongside Admin, but in this particular installation, Admin isn't displaying any administration links. The only links I have available to me are those to change my theme, and the create content links under its respective tab.



aaronbauman’s picture

Version:7.x-2.0-beta3» 7.x-2.x-dev
Category:support» bug
aaronbauman’s picture

Status:Active» Needs review

No idea where this patch came from, but it solves the issue you're reporting with a trivial fix to jquery.drilldown.js:

jotik’s picture

The patch at http://drupal.org/files/issues/admin_22.patch didn't fix this for me, even after clearing all the Drupal and browser caches.

HumanTex’s picture

I came across this same issue with the disappearing menu. I tried the patch, but found it did not fix the problem. With a little digging I eventually found that a CSS call from DHTML Menu (https://www.drupal.org/project/dhtml_menu) was using a 'display: none' attribute for the Admin's Administrator specific li/ul menu elements.

* Menus that are initially collapsed must be hidden statically.
* Otherwise, they will show up while the page renders, until JS runs.
li.dhtml-menu.start-collapsed ul {
  display: none;

Disabling DHTML Menu was the quick fix. I'll do without it for the time being instead of losing admin functionality. In the event the above patch really did provide a fix for something else, I'll leave that in as well.