Active
Project:
Lock Session
Version:
7.x-1.0-alpha1
Component:
Code
Priority:
Critical
Category:
Bug report
Assigned:
Unassigned
Reporter:
Created:
20 Jan 2012 at 03:56 UTC
Updated:
23 Jan 2012 at 03:49 UTC
Jump to comment: Most recent file
Comments
Comment #1
chertzogThe problem was that the lock session page had the path "admin/lock_session/login" and unless users have access to administration pages, they get a 403 error.
Here is a patch that removes the admin path, and adds a configuration setting to choose what roles should have their sessions locked.
The patch also corrects some grammatical errors, adds descriptions, removes a bunch of extraneous help comments, and corrects the module name in the info file. (That one threw me for a loop, when i went looking for "Lock Session" in the module list.)
This is against the Alpha release. I took a look at the dev release, and dont really know whats going on with it. The main functions have been removed and put into a plugin file for password policy.... which would require a dependency on that module.
But i have tested this patch with the alpha release and have found it pretty stable. Let me know of any issues.
Comment #2
nikemen commentedThanks! Well, I simply applied the patch and went to the configuration again, selected all roles and waited some minutes to test. Now I get a 404 error instead of the 403. The path given is http://my-site.org/?q=en/lock_session/login and the answer I get is:
Page not found
The requested page "/?q=en/lock_session/login" could not be found.
Comment #3
chertzogDo you have some sort of multi-lingual settings? the "en" at the beginning of the query path makes it look like you do. If so, im not sure how to handle that. I will have to do some digging.
Also did you clear all caches?
Try going to just
?q=lock_session/login
instead of
?q=en/lock_session/login
Comment #4
nikemen commentedMy wrong, sorry. I've now wiped the caches and it works fine. The site runs in 5 languages, yes, but apparently it has nothing to do. Thanks for your help!