Coming from #1318946: Notice: Undefined offset: 1 in libraries_get_version().
Apparently the authors of Facebook Connect were under the impression libraries_get_version would match the entire pattern, and not the first subpattern. They can't really be blamed, as that is not really explicitly stated anywhere.

Files: 
CommentFileSizeAuthor
#1 1323530-libraries-version-pattern-docs.patch1.8 KBtstoeckler
PASSED: [[SimpleTest]]: [MySQL] 128 pass(es).
[ View ]

Comments

tstoeckler’s picture

Status:Active» Needs review
StatusFileSize
new1.8 KB
PASSED: [[SimpleTest]]: [MySQL] 128 pass(es).
[ View ]

Here we go. I'll let this sit a few days, in case someone wants to review, otherwise I'll commit this as is.

sun’s picture

Status:Needs review» Reviewed & tested by the community
4haron’s picture

Hi,

Not very familiar with patches..

Any hint as to where to paste the patch text into?

Thanks!

4haron’s picture

4haron’s picture

oops. sorry. didn't mean to submit for a re test..

tstoeckler’s picture

Status:Reviewed & tested by the community» Fixed

Thanks for the heads-up. :)
Comitted to 7.x-2.x
http://drupal.org/commitlog/commit/10030/c5515bd18487b64744d4df7b3161985...

@4haron: See http://drupal.org/patch/apply for help

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.