Closed (fixed)
Project:
jQuery UI theme
Version:
7.x-1.0-alpha1
Component:
Code
Priority:
Normal
Category:
Task
Assigned:
Unassigned
Reporter:
Created:
13 Jun 2011 at 08:58 UTC
Updated:
7 Dec 2011 at 19:09 UTC
Feels a little hard to ask, but might you release this for Drupal 6?
Would love to use jQuery themes *properly*
Comments
Comment #1
chaby commentedAt the moment, i haven't downgrade it in D6. But i can do it as soon as i have time
Comment #2
doublejosh commentedThank, just wondering. If I have time on my project I might do it as well :)
Comment #3
puravida commented+1
I would also really appreciate this. Been spending hours updating & installing jquery only to get stuck with eggplant and hot_sneaks uploaded but can't figure out how to switch to that theme or get working in new content. Hopefully I will figure this out today but would still like to have this for our D6 implementation, since it will be quite awhile before enough modules are supported to allow an upgrade to D7.
Comment #4
chaby commentedI have create a 6.x branch available here. Only few things have not been done like :
It needs some reviews, could you do it please ?
Comment #5
chaby commentedA release have been done
Comment #6
doublejosh commentedAwesome, thank you!
Installed with drush and got this output...
Still installed, but the importer doesn't work in D6. Perhaps it should just require placing in the right folder?
Here's the error output...
Comment #7
chaby commentedFor the first error, could you tell me which version of php are you using ? I'm newbie but it seems that :
if ($var = variable_get('upload_extensions_default', NULL)) {//Do something}doesn't work properly depending on php version (?). I say that because it work fine for me with PHP 5.3.6. (check assignment rather than value returned ? If true, i have some cleanup code to do...).Anyway, i have just simply changed it to :
$var = variable_get('upload_extensions_default', NULL); if ($var) {//Do some something}. Could you tell me if error still occured ?Indeed, second error message is just a careless mistake ! But it means that you haven't zip extension php loaded : no zlib installed (PHP >= 5.2.0) or ZZIPlib (PHP 4). See. That why i have implement a hook_requirements() that you can check at admin/reports/status.
I'm still wooly about real environment requirements so correct me if i'm wrong.
This changes have been pushed on 6.x-1.x branch.
Comment #8
doublejosh commentedYeah, I'm on PHP 5.2.13
Will test soon.
Comment #9
chaby commentedSorry, I wasn't really awake when i wrote this !
Also, it would't change anything. Could you tell me what contains the variable 'upload_extensions_default' ?
drush vget upload_extensions_defaultshould return an array...(rather than a string as I expected)I
Comment #10
chaby commentedsounds resolved with last 6.x-1.0-alpha2
Comment #11
doublejosh commentedBTW: Here's the output...
upload_extensions_default: "jpg jpeg gif png txt doc xls pdf ppt pps odt ods odp"This problem seems to still exist in 6.x-1.0-alpha2
Error is...
Fatal error: [] operator not supported for strings in /home/recyclebetter/seabb/drupal/sites/all/modules/contrib/jqueryui_theme/jqueryui_theme.install on line 170Comment #12
doublejosh commentedYou need to remove the trim() on 163.
Comment #13
doublejosh commentedHowever, now it's stuck with: "The following file extensions are supported: . Maximun size..."
I dropped in another theme along side base in /default_themes but it doesn't register.
BTW: This page doesn't work: /admin/appearance/jqueryui-theme/example/MYTHEME
Comment #14
chaby commentedOk new release 6.x-1.0-alpha3 have been done.
You need to uninstall this module and install the new release as you have encounter some errors...
Before install new release, check if uninstall process have :
After install the new release :
Could you tell me if any errors still occured ?
If example pages don't work, which version of jQuery update module, jQuery UI module and jQuery UI theme are you using ? It seems that only 1.7 jQuery UI themes could be used (with of course a jQuery UI version of 1.7 and jQuery version 1.3). Appropriate js and stylesheets are loaded ?
Comment #15
doublejosh commentedBTW: Prior to a week ago, my upload_extensions_default did NOT include zip. So that was one piece of the problem... but that's just the upload tool.
sites/default/jqueryui_themedrush vget upload_extensions_defaultincludes zipdrush vget upload_extensions_defaultincludes zipPreview page works now for base!
Upload worked!*
Problems getting the new ones to register...
Thanks for the attention.
Comment #16
chaby commentedOK sounds like you haven't zip php modules, isn't it ?
$ php --modulesI supposed that at /admin/reports/status, you have a requirement error about no archiver detected.
You can take a look in this case at this php doc to install it. Personally i have do it with PECL...instead of compile PHP
Indeed, unzip manually jQuery UI theme don't solve the problem as it should be register in database and make some checks (which are done during import process or for the default jQuery UI theme "base" at module install).
Loading zip php module solve the import problem ?
Comment #17
doublejosh commentedGotcha. Didn't realize there were any database entries around the added themes.
I can't deal with recompiling PHP with
--enable-zipat the moment, but I did manually place the database row and can successfully get the theme placed and editable on the settings page.I think you can probably mark this as fixed.
Comment #18
chaby commentedThanks for your review
Comment #19
chaby commented