Varnish do not support https. It just skipped to backend.
so we should not apply esi block override for https requests.



brianmercer’s picture

nginx does support https and works with this module. Is this something that can be toggled in settings?

mikeytown2’s picture

Version: 6.x-1.0-beta1 » 6.x-2.x-dev

Moving this to 2.x and looking to make this an option.

mikeytown2’s picture

Title: ESI and HTTPS » ESI Varnish - HTTPS
Category: bug » feature

Moving to a feature request

manarth’s picture

Title: ESI Varnish - HTTPS » Add option to disable ESI for HTTPS requests
rjbrown99’s picture

Status: Active » Needs work
andypost’s picture

Version: 6.x-2.x-dev » 7.x-3.x-dev
Issue summary: View changes
Related issues: +#2670202: Use relative URLs for ESI

Suppose related issue will prevent using esi for https
The issue should update readme about no way to use it with tls