Closed (fixed)
Project:
SVG Image Field
Version:
2.3.x-dev
Component:
Code
Priority:
Critical
Category:
Task
Assigned:
Unassigned
Reporter:
Created:
9 Oct 2026 at 02:32 UTC
Updated:
6 Nov 2026 at 14:55 UTC
Jump to comment: Most recent
Composer blocks updates currently as ~0.22 has security vulnerabilities:
drupal/svg_image_field[2.3.5, ..., 2.3.x-dev] require enshrined/svg-sanitize ~0.22 -> found enshrined/svg-sanitize[0.22.0] but these were not loaded, because they are affected by security advisories ("PKSA-8j6w-3kr7-s9xk", "PKSA-6j95-1jtb-x6wc", "PKSA-cbx2-m9db-bmzd"). Go to https://packagist.org/security-advisories/ to find advisory details. To ignore the advisories, add them to the audit "ignore" config. To turn the feature off entirely, you can set "block-insecure" to false in your "audit" config.
These are fixed in 1.0.0
Start within a Git clone of the project using the version control instructions.
Or, if you do not have SSH keys set up on git.drupalcode.org:
Comments
Comment #3
acbramley commentedComment #4
jurgenhaasChanging this to critical, I would really appreciate a quick patch release to resolve the multiple CVEs.
Comment #5
mably commentedAnd it currently blocks upgrading to the new 3.2.5 release of the
svg_imagemodule which now requires^1.0forenshrined/svg-sanitize.Comment #6
timohuisman+1 on RTBC. Without a release we have to work around the ~0.22 constraint with a root-level inline alias or a repository override in every project.
Comment #7
aleixWhile waiting, workaround it with: composer require enshrined/svg-sanitize:'1.0 as 0.99'
Comment #8
tonytheferg commentedHit this too...
Comment #9
mandclu commentedThanks for raising this. I have merged in the change, and will work to get a new release out with the change quickly.
Comment #11
frondeau commentedHello,
I'm facing the problem on trying to get the version 2.3.8:
It returns the message:
Are you available to check where is the problem coming from ?
Thank you by advance.
Comment #12
frondeau commentedIt's OK with -W
omposer require 'drupal/svg_image_field:2.3.8' -Wis installing the the version 2.3.8.
Regards.
Comment #13
jwilson3The
-Woption, (a.k.a--with-all-dependencies) is generally a best practice when upgrading any contrib module, or even core.This was documented in the 2.3.8 release notes, but I've just clarified it further so it stands out and provided a second example (diff).
ProTip: I typically update contrib modules using the second example
composer require ...so that my composer.json file also gets the latest version explicitly stated and thereby stays in sync with what is actually installed in composer.lock. Usingcomposer update ...typically does not touch composer.json, and only updates composer.lock.Comment #14
jwilson3By the way, svg-sanitize version 1.1.1 was recently released, with even more security fixes. I recommend updating, and more generally, staying on top of Drupal modules and their transient dependencies using
composer auditfrequently.