Experimental Project

This is a sandbox project, which contains experimental code for developer use only.

EDIT: You only need this module if you are using release 2.11 of the openlayers javacript library.

Check the version you are using here: admin/structure/openlayers

In version 2.12 the problem with the google terms-of-service popup does not occur.

This small D7 module provides a block which when added to an OpenLayers map page will fix the issue described here: http://drupal.org/node/1540534.

Install and enable the module.
Go to Structure > Blocks (admin/structure/block).
Add the openlayers-google-popup-fix block to one of your regions.

You will normally configure the block to only appear on the same pages that your OpenLayers map appears on.

Project Information