I just installed 4.14 fresh on my server and everything looked great as it was installing. The final message came up and there was a link to continue to my site. I clicked on it and got a message saying the page was unavailable. The URL was:

http://MYDOMAIN.COM/?q=?q=?q=?q=?q=?q=?q=?q=?q=?q=?q=?q=?q=?q=?q=?q=?q=?...

I manually removed the ?q='s and just put admin to see if i can get to a page and it worked. It still seemed as though something wasn't right like there was a tools item at the top of the admin page with no description it thought that was odd. When you hover over it just shows the base domain URL which when clicked takes you to the one I put above.
I could go to different admin pages without issue. If I wanted to go back to the home page I got the URL with all the ?q='s and it failed.

I dumped the database and fully reinstalled again with the same issue.

First install I used this command:
composer create-project vardot/varbase-project:^8.4.14 8 --no-interaction

Second install I used this command however it did show it was installing 8.14:
composer create-project Vardot/varbase-project:^8.4.13 8 --no-dev --no-interaction

I will update the ticket shortly with my findings after I test the dev version.

Thanks
Shawn

Comments

staulien created an issue.

staulien’s picture

I installed the dev version and got the same result:

http://MYDOMAIN.COM/?q=?q=?q=?q=?q=?q=?q=?q=?q=?q=?q=?q=?q=?q=?q=?q=?q=?...

Here are some additional notes of my setup.
- I am using a multi-site setup currently only one domain in the mulit-site however the site file is pointing a different folder than default. I can do a fresh install using default if you wish that test to be done.
- My options selected during the install of 8.14 was that I selected everything except extra languages and the search.

I also noticed that i am getting alot of icons not showing up as well so I will keep looking to see what else but if there is anything needed to help let me know.

I appreciate the help. Thanks
Shawn

Mohammed J. Razem’s picture

What web server are you using?

Apache?

staulien’s picture

I have been messing around with different installs. Even Drupal 8.5 Beta1 plain install doesn't have the icons show up properly. The URL works so the ?q over and over is not happening on 8.5 beta1 but the icons in developer tools says

I am using:

lighttpd version 1.4.47-1
php 7.1.11-1
php-fpm 7.1.11-1

I think this might be something with just my setup. In developer tools for 8.5 beta1 the search button is an empty oval when I inspect it I see the following:

background: #f0f0f0 url(../../../../misc/icons/505050/loupe.svg) no-repeat center;

When I hover over the URL it says "could not load the image".

So something is wrong with my server configuration for the vanilla install of Drupal to not work.

Sorry for opening the ticket.

Thanks
Shawn