i am getting this error frequently , this not occur on anonymous user this only occur when i am loging in with admin .
i am using openpublish 7.x distribution
i searched on google most people recommend , clear cache (previously this rick worked for me but no luch this time ) i checked mysql configuration all the time out and max packet size values are too high on amazon RDS , the php max execution time is 600 sec so i dont think so its problem with DB side .
any pointers will helpful .
*previously i also tried to run update.php and it worked for me but not this time .

Fatal error: Uncaught exception 'PDOException' with message 'SQLSTATE[HY000]: General error: 2006 MySQL server has gone away' in /var/app/current/mysite/includes/database/database.inc:2139 Stack trace: #0 /var/app/current/mysite/includes/database/database.inc(2139): PDOStatement->execute(Array) #1 /var/app/current/mysite/includes/database/database.inc(664): DatabaseStatementBase->execute(Array, Array) #2 /var/app/current/mysite/includes/database/database.inc(2318): DatabaseConnection->query('SELECT expire, ...', Array, Array) #3 /var/app/current/mysite/includes/lock.inc(167): db_query('SELECT expire, ...', Array) #4 /var/app/current/mysite/includes/lock.inc(146): lock_may_be_available('theme_registry:...') #5 /var/app/current/mysite/includes/theme.inc(447): lock_acquire('theme_registry:...') #6 /var/app/current/mysite/includes/bootstrap.inc(427): ThemeRegistry->set(Array) #7 [internal function]: DrupalCacheArray->__destruct() #8 {main} thrown in /var/app/current/mysite/includes/database/database.inc on line 2139

Comments

b rajesh’s picture

Status: Active » Closed (fixed)

i restored my old backup site and issue fixed